WordPress.org

Ready to get started?Download WordPress

Forums

Easy Testimonials
[resolved] Plugin Causes Issue w/ Featured Image on Posts + Pages (17 posts)

  1. TheGG
    Member
    Posted 1 year ago #

    Ugh!

    Unfortunately, after spending most of the day transferring all of my Testimonials into the Plugin, I realized it actually disabled the "Featured Image" option on all my new Posts + Pages! :(

    SO disappointed. I finally thought I had found a solution that I had been looking for for months!

    Is there a fix for this???

    I love this plugin! It's so easy to use otherwise!

    Please help!

    Thanks! :)

    http://wordpress.org/plugins/easy-testimonials/

  2. richardgabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hey!

    So, can you give me some more information about how your site is currently setup?

    I am using Featured Images, on the Testimonial custom post type, as part of its functionality. It sounds like there may be a conflict with how I have that implemented and how you have your site configured.

    Thanks!
    Richard

  3. TheGG
    Member
    Posted 1 year ago #

    Hey Richard!

    Thanks for getting back to me! :)

    Sure, just tell me what info you need from me.

    I noticed that the "Featured Image" option is gone only on a NEW Post or Page. On old posts or pages, the featured images or options for a featured image is still there.

    Hope this helps!

    Thanks! :)

  4. pratikshrestha911
    Member
    Posted 1 year ago #

    hi,
    I have this plugin installed and have the same problem. As I enable the plugin, my featured images tab on pages and posts disappear and as soon as i disable it, it comes back on again. However the previous featured images that i have set is there, i just cannot alter of add new featured images after i activate easy testimonial plugins.

  5. richardgabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hello!

    I have just pushed an update that I believe will address this issue. It turns out that add_theme_support will overwrite any pre-existing options. I have updated my code so that this should not be an issue, moving forward.

    Will you please try the update and let me know if I can mark this topic resolved?

    Thanks!
    Richard

  6. TheGG
    Member
    Posted 1 year ago #

    Hey Richard.

    Updated + nope, didn't work :/

    Thanks,
    Danielle :)

  7. richardgabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Dang - I put out an update, it had a separate issue, I fixed that issue, now back to square one. Thanks for bearing with me, here!

  8. TheGG
    Member
    Posted 1 year ago #

    Haha. No prob.

    One more question too while I have you here...

    Is there any way to get the "Client Name" info to appear directly under (lined up with) the text, instead of lining up with the picture?

    Example of it unaligned (with East Testimonials) here: http://www.glamorganicgoddess.com/testimonials-test/

    Example of it lined up (but not using Easy Testimonials) here: http://www.glamorganicgoddess.com/praise/

    Obviously, the testimonial texts that are shorter tend to line up, but the ones that are longer don't. Is there some HTML code that I might be able to include in the "Client Name" to fix that? I played around with this for a few hours the other day + couldn't get it to do anything.

    Thanks! :)

  9. richardgabriel
    Member
    Plugin Author

    Posted 11 months ago #

    Hey GG -

    So, better late than never, I guess.

    I have pushed out an update today that should both address the Featured Image issue as well as allows you to apply Custom CSS to the output of the plugin.

    With Custom CSS you should be able to achieve your goals, if you're familiar with CSS.

    Anyways, I apologize for the much delayed reply.

    Please let me know if you need anything else!

    Thanks,
    Richard

  10. TheGG
    Member
    Posted 11 months ago #

    Hey Richard!

    Thanks so much for getting back to me! :)

    Seems like the featured image page / post issue is fixed on my end... Yay!

    Ok, now here's a link to my Easy Testimonials Test Page, so how do I line up the line with their name, link + title, using the CSS in the settings?

    As you can see, on the longer ones (Stephanie + Kerri) - don't line up directly underneath the above text, but the shorter ones (all the others) automatically do. How do I fix this?

    Thanks! :)

  11. valerama
    Member
    Posted 11 months ago #

    I hacked the plugin and took the whole thumbnail section out of there and just added testimonials to my functions.php

    I was kind of in a hurry so I didn't play with other options.

    Hope you get this part fixed. I don't know that the thumbnails can't be turned on with the straight code add_theme_support() without checking to see if it exists. When I've made plain CPTs I've never had to do anything special to that bit of code.

  12. richardgabriel
    Member
    Plugin Author

    Posted 11 months ago #

    @Valerama:

    As far as I know, the Featured Image issue is fixed in the most recent update. Due to how add_theme_support works, I was wiping out previously activated Featured Images in a few specific scenarios (that are relatively common.) get_theme_support allows me to detect and activate Featured Images, as needed.

    Thanks!
    Richard

  13. richardgabriel
    Member
    Plugin Author

    Posted 11 months ago #

    @TheGG:

    You'll need to play around with CSS. I think something like this may work:

    blockquote.easy_testimonial {
    margin: 10px auto;
    padding: 10px 10px 10px 125px;
    position: relative;
    }

    .easy_testimonial .pibfi_pinterest {
    display: block;
    left: 0;
    position: absolute;
    }

  14. TheGG
    Member
    Posted 11 months ago #

    Hey Richard!

    TY!

    Ok, let me play around with this a little bit + get back to you in the next week or so!

    Thanks! :)

  15. TheGG
    Member
    Posted 10 months ago #

    Sorry for the delayed response Richard :/

    Refresh my memory... where do I put the CSS?

    Thanks! :)

  16. TheGG
    Member
    Posted 3 months ago #

    Hey Richard!

    So... I've decided to try to play around with this again, but am still having the "Client Name" alignment issue (as I stated in my comment above, several months ago).

    Where do I put the CSS code?

    You can see it here, with Keri, Stephanie + Sue.

    Also, I'm having 2 other issues...

    1. On the longer Testimonials, like Keri's - the testimonial (from the post area) is wrapping. How can I stop that?
    2. On the shorter ones, like Susie's - the picture is too close to the one below!

    Please help!

    Thanks! :)

  17. TheGG
    Member
    Posted 3 months ago #

    So... I figured out where to add the CSS - it's on the settings page.

    However... I can't seem to get the Testimonial Images to show up on the left hand side, next to the testimonials... they are appearing above them, on the top left of each one.

    Please help!
    Thanks! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic