WordPress.org

Ready to get started?Download WordPress

Forums

Category Order and Taxonomy Terms Order
[resolved] Categories disappearing in WP Multisite (3 posts)

  1. rocboy001
    Member
    Posted 1 year ago #

    Hey!

    Great plugin. I'm in love with this thing!

    There is a bug/error that I found with the plugin however, with WordPress Multisite. The plugin works with the main domain that MUltisite is installed on, but when activated it makes all of the other subdomains and external domain categories disappear. You're not able to view and create new categories on the children domains.

    Specifically when Admin Sort is checked, no posts display in the front end in the child themes The parent theme's categories still show however.

    Thanks again for an awesome plugin!

    http://wordpress.org/extend/plugins/taxonomy-terms-order/

  2. rocboy001
    Member
    Posted 1 year ago #

    Hello.

    OK, So I think I may figured out the problem... but not the solution!

    This problem is not just only limited to this plugin, but also other category reorder plugins I tried.

    Basically, If the plugin is "Network Activated", the categories in subdomains and external domains are not displayed (they basically disappear) in the backend so you cannot reorder them.

    BUT if the plugins are activated individually from each subdomain / external domain, than the plugins work!

    So I am assuming there may be a code/snippet for categories specifically for WordPress Multisite that is causing this error in all category reorder plugins.

    The strange thing is, plugins for post types still work even when it is "Network Activated"

    I originally thought that the problem may have arisen from global_terms_enabled w/ MU, so I disabled it, but the problem still occurred.

    Would love the feedback of these plugin developers to chime in and see if this is something that can be fixed!

    Thanks!
    Roc.

  3. nsp-code
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Roc
    As you figured out, you will need to activate the plugin within each individual blogs instead use the Network Activated. This is not a bug, it require additional code on which we are still working.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic