WordPress.org

Ready to get started?Download WordPress

Forums

Category Meta plugin
Plugin Doesn't Save Meta Information (12 posts)

  1. emcoward
    Member
    Posted 2 years ago #

    Hi,

    I'm having trouble using this plugin with WordPress 3.2.1. The plugin seems to install correctly and allows you to define meta fields for categories. However when you try to save the category with the new fields nothing happens. The plugin doesn't seem to create the relevant tables in the database to save the data.

    Any help with this would be greatly appreciated.

    Emily

    http://wordpress.org/extend/plugins/wp-category-meta/

  2. randyhoyt
    Member
    Plugin Author

    Posted 2 years ago #

    I'm not the developer of the plugin, but I managed to figure out how to make it work for me on WordPress 3.3.1. I hope you'll give it a try and post any feedback over there. You can download the code from the GitHub repository I created for it:

    * https://github.com/randyhoyt/wp-category-meta

    (You can download it by clicking on the ZIP image in the top left corner, right under the top navigation.)

  3. davidjs
    Member
    Posted 2 years ago #

    I just installed the version from github and it still does not work, The meta does not save after editing a category..

  4. pcouture
    Member
    Posted 2 years ago #

    Had this issue to. You need to make sure the name of the plugin folder is 'wp-category-meta'

    Randy you should rezip your file so the foldername is correct when packaging.

  5. randyhoyt
    Member
    Plugin Author

    Posted 2 years ago #

    @pcouture - Feel free to take my code fix, package it up, and make it available for download on some web hosting you control. That would be a great way to help out the community!

  6. dr-kos
    Member
    Posted 1 year ago #

    the problem remains pressing for version 3.4.2 with plugin folder name 'wp-category-meta'

  7. randyhoyt
    Member
    Plugin Author

    Posted 1 year ago #

    What version of the plugin are you running? The last version the original developer(s) released was 1.2.4, but that one will probably never work again. Have you downloaded my code from Github? I released 1.2.7 a couple of weeks ago, which you can download here:

    * https://github.com/randyhoyt/wp-category-meta/tags

  8. unaghii
    Member
    Posted 1 year ago #

    I had the very same problem and @randyhoyt's version does the job. Thanks!

  9. vladv
    Member
    Posted 1 year ago #

    Hi there,

    I assume the problem is back in the v. 3.4.2 of WP.

    I tried to use randy's version and rename the folder to 'wp-category-meta' but didn't work.

    Any help would be appreciated.

    Thanks, V.

  10. randyhoyt
    Member
    Plugin Author

    Posted 1 year ago #

    It's working just fine for me on WordPress 3.4.2. I would suspect a plugin conflict. What other plugins are you running?

  11. vladv
    Member
    Posted 1 year ago #

    Actually, I found out what was causing the trouble - I had a slightly modified path to upload folder in the 'Settings -> Media'. When I switched it back to 'wp-content/uploads', the category images started to work.

    Anyway, I solved my problem before I found out about this using a 'Category Images II' plugin. (But I had to "fight" with that plugin as well a little bit in the source code...)

    Thanks for your time!

  12. randyhoyt
    Member
    Plugin Author

    Posted 1 year ago #

    Thank *you* for posting the fix to your problem. I'll take a look at the plugin and update it so that it works even with a modified image path.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic