WordPress.org

Ready to get started?Download WordPress

Forums

CataBlog
"Previous" shows when only one page available (10 posts)

  1. amir_fayez
    Member
    Posted 2 years ago #

    When using the limit keyword in the short code and when only one page is available the word previous still shows in the paging line.

    My fix:
    In CataBlog.class.php located in \wp-content\plugins\catablog\lib\

    Find private function frontend_build_navigation:

    Change if ($paged < 2) to if ($paged < 2 && $total > 1)
    Change if ($paged == $total) to if ($paged == $total && $total > 1)

    This will prevent paging from showing if only one page is available

    Thanks,
    Amir

    http://wordpress.org/extend/plugins/catablog/

  2. macguru2000
    Member
    Plugin Author

    Posted 2 years ago #

    You can also add this to your site's CSS code, without hacking the plugin, to stop the previous link from appearing.

    catablog-first-page-link.catablog-disabled {
      display: none;
    }
  3. mcvanz
    Member
    Posted 1 year ago #

    dear macguru,

    I've two question:
    - your solution is in absolute better then amir_fayez one?
    - where exactly you propose of copying the code above?

    Thanks a lot!

    Roberto

  4. mbrsolution
    Member
    Posted 1 year ago #

    Hi mcvanz you add the CSS code to your theme style.css file of course depending on how your theme is set up. If you can provide your URL we might be able to check for you.

    Kind regards

  5. mcvanz
    Member
    Posted 1 year ago #

    Thanks a lot!
    At this moment I've used the amir_fayez solution and everything works well! If there's no a "collateral effet" I'd left all like now... It's reasonable?

  6. mbrsolution
    Member
    Posted 1 year ago #

    Hi that is good to know but remember the moment you update the plugin you will loose those settings. That is why it is always best to implement what Zach mentioned by adding the CSS code in your theme or child theme.

    I always prefer to add a child theme that way I know that no matter how many times I update the theme or in this case the plugin it will not affect the CSS code I added to the child theme.

    I hope this helps you.

    Kind regards

  7. mcvanz
    Member
    Posted 1 year ago #

    ok, understood. ;) so.. my temporary home URL is: http://www.catmex.net/wordpress

    If you can help me to modify my themeCSS I'd be very grateful.. I've Never touched this file and I'm very rookie in this matter! Thanks for every step-by-step correction!

  8. mbrsolution
    Member
    Posted 1 year ago #

    Hi, what would you like to modify from your theme? Also your website is very slow. Use the following URL http://gtmetrix.com/ to test your website and you will see how slow.

  9. mcvanz
    Member
    Posted 1 year ago #

    My modify was principally the same of amir_fayez: remove the navigation word "previous" in a single page gallery.

    About website speed... thank for your reccomendation... i'm still working on this site and surely something is still to repair; thanks a lot for your segnalation of gtmetrix! very useful!

  10. mbrsolution
    Member
    Posted 1 year ago #

    Hi, try and add the CSS code from above to your theme style.css file or what every CSS file it is using. Also can you point to a page where the above mention error was occurring so that I can check to see what CSS file your theme is using.

    Kind regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic