WordPress.org

Ready to get started?Download WordPress

Forums

Capability Manager
Editor cannot add to menu but can edit / delete ! (6 posts)

  1. Felix2001
    Member
    Posted 3 years ago #

    Hi, The editor role I have created cannot add to the site main navigation menu, but strangely they can delete edit or move existing menu items.
    (This is under appearance > menus )

    I have installed the Capability Manager. And have given "Edit theme options" capability to the editor. The editor can see The appearance menu in wp-admin, and the sub menus under that: Widgets, Menus, Background,Header.

    As admin I have no problem doing this, so something in the capability of the editor is stopping me, here is a list of the capabilities I have assigned to the editor role:

    Delete pages
    Delete published pages
    Edit files
    Edit theme options
    Edit others pages
    Edit private pages
    Read
    Unfiltered html
    Upload files
    Moderate comments
    Read private pages
    Unfiltered upload
    Delete others pages
    Delete private pages
    Edit pages
    Edit published pages
    Publish pages

    Am I missing something or is this a bug?

    Cheers for any help or pointers!!

    http://wordpress.org/extend/plugins/capsman/

  2. Felix2001
    Member
    Posted 3 years ago #

    edit:

    When I click "Add to Menu" after selecting the page I want to add, the new menu item looks like it is created, but then when I hit "Save Menu" wordpress reports: "The main nav menu has been updated." but removes the new item so no change is actually made.

    Any thoughts??

  3. Felix2001
    Member
    Posted 3 years ago #

    After some trial and error, I found how to fix I had to add the capability to of "Edit posts" to "editor" to get this to work properly even though I am not using posts on the site, just pages. I will now have to find a way to remove posts from the side menu for editors.

    Hope this helps someone.

  4. jealouz
    Member
    Posted 3 years ago #

    Hi, I have been searching for a fix for this same issue.
    Big THANKS to your post!
    I enabled "Edit Post" for user editor.. works!

    Also, so remove/hide the "POST" from editor nav you can use Adminimize
    http://wordpress.org/extend/plugins/adminimize/

  5. renini
    Member
    Posted 3 years ago #

    I was looking for the samething thanks man!

  6. sumtech2008
    Member
    Posted 2 years ago #

    Thanks for figuring this one out! I had the same issue and couldn't figure out what was going on here.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic