WordPress.org

Ready to get started?Download WordPress

Forums

Business Directory Plugin
[resolved] HELP! Site is down (14 posts)

  1. lujeffcoat
    Member
    Posted 1 year ago #

    Hello, I received a notification in the backend of my site that said Business Directory requires you to have a Title and Category Field. You can manage these under Manage Form Fields. (I had changed my Title field to say "Name"). I went in and changed "name" back to "title" and saved it. I got a second notification that said Business Directory requires you to have a page with the short code [businessdirectory] in order to function properly. I went in and changed the old short code [WPBUSDIRMANUI] to the new short code [businessdirectory] and my entire site crashed. Now I can't access the front end or the backend. Please help!
    http://www.visitncwinecountry.com/

    http://wordpress.org/extend/plugins/business-directory-plugin/

  2. lujeffcoat
    Member
    Posted 1 year ago #

    Front end just came back up, but when I try to log into the backend, I get a message that says: You do not have sufficient permissions to access this page.

  3. businessdirectoryplugin
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Lauren,

    Yes, BD does require those fields. Can you tell me what you did prior to this error? It sounds like you deleted those fields in the database or something (we wouldn't have let you do it from the Admin panel!). You had the directory setup so these errors sound like the result of something else bad that happened.

    Have you installed new plugins? Done some kind of upgrade? BD upgrades would not cause this sort of issue.

  4. lujeffcoat
    Member
    Posted 1 year ago #

    I haven't run a wordpress update. I did install a maintenance mode plugin the night before this happened. I have since backed up my site using a backup from 9.21.2012, but that didn't help. I still can't access my admin section, and now a lot of my links have changed. I've tried moving plugins to another folder, renaming my theme, changing the permissions, and deactivating plugins using the phpmyadmin (which I never touched before, so I definitely didn't change or delete any fields manually).

    Since I ran the backup, the plugin that I last installed is no longer there. Also, when I look at the database, I can see the field "name" is still there and has not been deleted. At this point, I have tried everything that I know to try and can't find any other solutions. I desperately need to get my site back up and running. Now I can't even figure out how to re-activate the plugins that I disabled and have my site is completely not working. Any advice or help is very much appreciated.

  5. businessdirectoryplugin
    Member
    Plugin Author

    Posted 1 year ago #

    For the plugins you're having trouble with, go to the WP Admin Dashboard under Plugins->Installed Plugins. Re-activate anything that you used to have in there.

    If they are gone, that is the result of the backup being restored. You'll have to piece that together from memory or perhaps you have a file backup laying around somewhere?

    Is the missing plugin you're referring to Ratings? You can reinstall that from the downloaded file you got saved locally when you got the file from me.

  6. lujeffcoat
    Member
    Posted 1 year ago #

    That's the problem - I cannot get to my WP Admin Dashboard - I get a message that says "You do not have sufficient permissions to access this page." when I try to login.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    FTP into your site (or use whatever file management application your host provides) & delete the wp-content/plugins/business-directory-plugin folder.

  8. lujeffcoat
    Member
    Posted 1 year ago #

    If I delete it, will I lose all of my listings on the site? Also, I did try moving the Business Directory Folder and that did not change anything.

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Sorry - I have no idea. I'm not connected to this plugin in any way.

  10. lujeffcoat
    Member
    Posted 1 year ago #

    Thanks - I created a backup of that folder and deleted Business Directory Folder. Still unable to log into WP Admin. I have replaced the Business Directory file that I had removed. No changes. Any other suggestions? I no longer have the Ratings Module installed (at least I don't see it anywhere after doing the backup). All of these issues started right after installing that. Not sure if it's related or just a coincidence, honestly. This is still the error I get when trying to log in to WP Admin:

    Notice: Undefined index: name in /home/content/62/9050062/html/wp-includes/capabilities.php on line 113
    You do not have sufficient permissions to access this page.

  11. businessdirectoryplugin
    Member
    Plugin Author

    Posted 1 year ago #

    I don't believe ratings had anything to do with this particular error. I have it installed on the main demo site--no issues. Dozens of others have installed it at this point, no reported issues like this.

    That particular error sounds like your WordPress install is corrupted somehow. It's not from BD code. You might contact your web hosting company and ask if they can restore a clean version of your WordPress to your site.

    But before you do that, be sure to BACK UP everything locally--themes, plugins, any misc files...I'd pull everything. And then have them try it.

    I can email you the ratings plugin again so you have a copy as well.

  12. lujeffcoat
    Member
    Posted 1 year ago #

    Okay, thank you. I appreciate you looking into it. I didn't think it was a ratings issue either, but wasn't sure because of the way everything happened. I'll email you for the ratings once I've got everything running. Do you know how I can save a copy of all of my directory listings? I'd hate to have to re-enter ALL of that content after a fresh install.

  13. businessdirectoryplugin
    Member
    Plugin Author

    Posted 1 year ago #

    Deleting BD from your plugins directory will NOT cause you to lose ANY listings at all. If you delete it from the Plugins area of your WP Admin it may (I don't recall off hand). But deleting it using FTP or SCP is safe FYI. Since you can't get to WP Admin dashboard anyhow, this sounds like your only solution.

    Since this all started happening when you added the Maintenance Mode plugin, I would highly suggest removing it FIRST and then seeing what happens. Conflicts like this are generally the "last one installed", so getting rid of it may clear things up.

  14. lujeffcoat
    Member
    Posted 1 year ago #

    Thanks. Unfortunately, when I restored my backup file, the maintence plugin isn't showing up anymore, so I can't manually remove it. Not sure if something in the database got screwed up when I added it. I'm going to run a full backup of my database using phpmyadmin, and hopefully that will save my BD listings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.