WordPress.org

Ready to get started?Download WordPress

Forums

Business Directory Plugin
[resolved] Google Map Plugin - Sensor parameter issue (14 posts)

  1. MCM
    Member
    Posted 2 years ago #

    I cannot see the google map, on browsing to the page it gives me an error.

    "The Google Maps API server rejected your request. The "sensoor" parameter specified in the request must be set to either "True" or "false".

    I am using latest version of maps and directory and latest WP 3.4.1.

    PLEASE HELP!

    http://wordpress.org/extend/plugins/business-directory-plugin/

  2. MCM
    Member
    Posted 2 years ago #

    I am using php 5.4.4 but tested on my local machine php 5.4.3 not sure if this makes a difference.

  3. MCM
    Member
    Posted 2 years ago #

    It occurs on both instances, but I had to disable it on my live website as users would get this message on every page.

  4. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    ]\Can you tell me what parameters/fields you are using in the Google Maps API? A complete list would help.

    Also, what listing does it choke on, so we can try to reproduce it locally? A link would be most helpful.

  5. MCM
    Member
    Posted 2 years ago #

    I had to switch off your plugin otherwise my users would get that pop up on every page. Consider placing conditional statement that the google js only loads on the necessary pages.

    I am using all the fields from the available fields, address, state etc.

  6. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    It's possible several things could be going on here--I need you to try some things out:

    - What about temporarily disabling all other plugins? Does that fix the behavior with Google Maps on? (that would mean a plugin conflict)
    - What if you use fewer fields? Like only address and city/state?

    I need to be able to reproduce this to fix it. We're definitely not seeing this locally (I have Google Maps installed on the demo: http://businessdirectoryplugin.com/business-directory/ and it works fine.

  7. MCM
    Member
    Posted 2 years ago #

    I googled this and happens on several other plugins. I am using php 5.4.3 and php 5.4.4 on my local test site and live website.

    My local website has 1 or 2 plugins like page-navi so it is not that.

    I read some stuff and perhaps your code is also not doing this...

    <script type='text/javascript' src='http://maps.googleapis.com/maps/api/js'></script>

    This line of code should have the sensor param set but is getting chopped off somehow. Some other dev/person had the same issue but they did not get resolve

  8. MCM
    Member
    Posted 2 years ago #

    alert("The Google Maps API server rejected your request. The \x22sensor\x22 parameter specified in the request must be set to either \x22true\x22 or \x22false\x22.")

  9. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    Perhaps it related to PHP 5.4. Can we get admin access to your site to see it in action? You can leave it disabled for now. Use the contact form http://businessdirectoryplugin.com/contact/

  10. MCM
    Member
    Posted 2 years ago #

    Download XAMP Beta

    http://www.apachefriends.org/en/xampp-beta.html

    I am testing on my local machine using this.

    Clean install of WP + your plugins (bd and google map)
    activate and you will see the errors.

  11. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    OK, I sent an updated module for you to try. Let me know how it goes.

  12. MCM
    Member
    Posted 2 years ago #

    Apologies I found the issue. In my functions.php I had the following code

    /* This handles the  "Remove query strings from static resources" issue (PERFORMANCE - CACHING) */
    function _remove_script_version( $src ){
    	//$parts = explode( '?', $src );
    	//return $parts[0];
    }
    //add_filter( 'script_loader_src', '_remove_script_version', 15, 1 );
    //add_filter( 'style_loader_src', '_remove_script_version', 15, 1 );

    This was chopping off the sensor param thing.

  13. bizdirectorysupport
    Member
    Posted 2 years ago #

    So the problem is resolved?

  14. MCM
    Member
    Posted 2 years ago #

    Yes, thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.