WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] links are broken (8 posts)

  1. Peter
    Member
    Posted 2 years ago #

    hi guys,

    I've installed the bulletproof security for wordpress without reading the instructions, and i've since destroyed my links. When I click a link such as contact us, I get a 404 error:
    Not Found

    The requested URL /wordpress/index.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    This is for every link on my website - nav bars, links, pictures... everything. I did eventually read some stuff, which indicates that I should change my links to numbers not words, however I don't want to do this. So I'm left with no other option other than to uninstall. I have deleted the .httaccess file from the public_html folder, and have selected this:
    Default Mode
    WP Default htaccess File

    and this:
    Delete wp-admin
    htaccess File

    Since doing those, my pictures now work, but I still cant load any pages or links on my website.
    My site is sisoit.com

    Thanks,
    Alexander.

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    The first step is creating a custom permalink structure if you want to use .htaccess mod_rewrite on your website. You would go to Settings >>> Permalinks and pick or create a custom permalink structure. See this post on Custom Permalink Structures >>> http://www.ait-pro.com/aitpro-blog/2304/wordpress-tips-tricks-fixes/permalinks-wordpress-custom-permalinks-wordpress-best-wordpress-permalinks-structure/

    If you do not want to use a custom permalink structure then just delete all .htaccess files. You will not be able to use BPS if you do this.

    Thumbnailer scripts are blocked by default - this will change in about 6 months (i want to give people plenty of time to fix their Thumbnailer scripts so their websites do not get hacked) - for now you need to manually choose to allow thumbnailer scripts on your site by changing this in the BPS Root .htaccess file - instructions are included in the root .htaccess file.

    So if you do decide to use BPS again.
    1. You need to create a custom permalink structure - every WP site should be using a custom permalink structure.
    2. You then click the 2 AutoMagic buttons to create your Master .htaccess files.
    3. You then activate all BulletProof Modes.

    For people who already have existing .htaccess files be sure to back them up first before activating BulletProof Modes.

  3. Peter
    Member
    Posted 2 years ago #

    Hey mate,

    Thanks for the quick reply. So before I deleted the .httaccess from the root folder, it says this when I click on a page link:
    Not Found

    The requested URL /wordpress/index.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Now that I have removed .httaccess it says this:

    Not Found

    The requested URL /au/about-us was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I've also disabled the plugin and I still get the 404 error.
    Could I be doing something wrong or missing a step (or 2... maybe 10) :P

    Cheers,
    Alexander.

  4. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    There are only 2 steps - Click AutoMagic buttons and Activate BulletProof Modes - very simple and very easy.

    Ok so i see that you are using a default URL structure ?p=1 and not a custom permalink structure.

    My site is sisoit.com

    You have a root site that looks like it was just installed with no content yet and does not have any links going to /wordpress or /au. So without any real info for me to look at I really can't guess what is going on. The links you do have on this site are all working correctly.

    It appears you have Private Name Servers: ns2.sisoit.com, ns1.sisoit.com, but whether or not you have dedicated, shared or VPS hosting does not matter - BPS works on all of types of hosting accounts.

    I would need the exact details of the issue because from what i am seeing everything is working fine.

  5. Peter
    Member
    Posted 2 years ago #

    Thats very strange, I've had a redirect going from sisoit.com to sisoit.com/au/ but it seems to have removed itself. Its fixed now so you should get redirected.

    Please try http://www.sisoit.com/au/

    Cheers :)

  6. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    Yep i can see the /au/ directory now.
    Redirect? How are you redirecting the site? with .htaccess?

    Wow the resource drain is off the charts - my CPU was pegged at 99% until i disallowed all scripts from running on your site.
    Looks like some serious coding problems on this site. Probably just too much going on all at once. Thank god for FF - NoScript. ;)

    i see /au/category/portfolio/logos in the path to a menu item. The other menu items appear to be pages - BPS would not be interfering with these because they would be direct URL links. ie no rewriting occurring.

    I think what you need to do at this point is take another look at your navigation menu coding. That appears to be the problem and not BPS. And the redirect may have something to do with the problem as well.

    Also this is a big clue - when i look at your page source code the Privacy page URL is a page ID, but when you click on the link the URL is going to a page name URL that is not being rewritten correctly???

    Also double check your permalink structure. If you have a typo in that structure then you will typically get 404 errors.

  7. DavidRamos
    Member
    Posted 2 years ago #

    Hello AITpro:

    I am actually having the same issue, I just installed the plugin, spend 2 hours with the hosting company on phone after my site went down. After bring the site up, we disable the plugin but the links still broken. Basically is not showing any pictures on frontpage etc. Maybe you can give us a hand here. All help we can get is pretty much appreciated.

    http://www.brokerpulse.com

  8. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    There is a problematic .htaccess rule in .46.6 that affects some web hosts depending on certain conditions that the web host is doing / using and i have just decided to remove that rule instead of compensating for these web hosts - will be removed in .46.7. It appears that at least one problem may be caused by ZendGuard, but this is not conclusive yet.
    More Info >>> http://www.ait-pro.com/aitpro-blog/3429/wordpress-tips-tricks-fixes/bulletproof-security-403-forbidden-errors-troubleshooting/

    Your site is using a thumbnailer script. Please see the root .htaccess file to change the Forbid rule to a Skip rule.
    /wp-content/themes/tribune/scripts/timthumb.php?src=/wp-content/uploads/2011/12/x4.jpg&w=300&h=350&zc=1

    Please provide more information about what steps you took after installing BPS.

    BPS set up should follow these 4 simple steps.
    1. You must have a custom permalink structure.
    2. Use the built-in BPS Backup to backup your existing .htaccess files (you may or may not have any existing .htaccess files).
    3. Click AutoMagic buttons.
    4. Activate BulletProof Modes

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.