WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Issues with 4.72, activating bulletproof mode for root is bringing si (9 posts)

  1. Keith Aldrich
    Member
    Posted 1 year ago #

    After updating to 47.2, activating bulletproof mode for the root folder is killing a site I manage.

    I created new default and secure htaccess files with the automagic buttons before activating.

    I've been able to restore the old htaccess via the bps backup folder, but am still having issues activating bulletproof mode.

    A couple of notes:
    *I've never been able to change file permissions for the root htaccess on this site to 404 because that would cause a server error. So I've ended up leaving them at 644
    *I have W3 Total Cache installed on this site.
    *I was able to upgrade, and activate bulletproof mode without any problems on another site (different host).
    *The site in question is hosted at pair.com

    Any assistance would be appreciated.

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    *** Update ***
    I just noticed that you said your Host was Pair Networks so disregard the .htaccess file restriction "Or it could mean..." possibility - BPS works fine on Pair.

    Not being able to change .htaccess file permissions to 404 most likely means that your Server is configured with DSO.

    Or it could mean that your Host has added a specific file permission setting/limitation for .htaccess files. I only know of one Parent Company that owns several smaller hosting companies that does this - if your host is under the Parent Company Landis Holdings then BPS will not work on your website.

    Please go to the BPS System Info page and post this information in your reply.
    Server Type:
    Operating System:
    Server API:

  3. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    No response resolving this post. If the problem is still occurring then please post the requested System information.

    Please go to the BPS System Info page and post this information in your reply.
    Server Type:
    Operating System:
    Server API:

  4. Keith Aldrich
    Member
    Posted 1 year ago #

    Sorry for the delayed response, I've been out of town for a few days.

    Server Type: Apache/2.2.22
    Operating System: FreeBSD
    Server API: cgi-fcgi - Your Host Server is using CGI.

  5. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Ok the Server API is CGI, but since you cannot activate bulletproof mode then most likely this particular Server is using group ownership permissions that will not allow you to do things like copy files from within WordPress/BPS. Also since you cannot change the root .htaccess file permissions to 404 then this Server has strict restrictions on changing .htaccess files to anything other than 644 permissions. At this point you will need to check with this host and ask them these Server questions below.

    1. I have a WordPress plugin that is trying to copy a file from within the WordPress Dashboard and that file copy is not being allowed. Why would the file copy be blocked or not allowed on this Server?
    2. I have tried to change the file permissions for an .htaccess file to 404 and I got a Server Error. Is it possible to change the .htaccess file permissions to 404? If not, why is this not possible on this Server?

  6. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Comment was revised/reworded.

  7. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Resolving. this issue is a specific permissions issue on a specific server for this Host. 404 permissions are just not allowed on some Host's Servers and 644 permissions will need to used for .htaccess files.

  8. Keith Aldrich
    Member
    Posted 1 year ago #

    Thanks for the fast replies. I'm sorry that I haven't been more prompt in getting back to you.

    I should have mentioned...I was able to activate Bulletproof mode before the latest update, although I had to leave the permissions for the root htaccess at 644.

    Regardless....Is there a way I can activate bulletproof without messing with permission. IE, Can I create the Bulletproof htaccess for the root folder and then try to copy it manually?

    Again, thank you for your time!

  9. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Yep that option is also available to you.

    When you click the AutoMagic buttons you are creating customized master .htaccess files for your website. When you activate BulletProof Mode for your root folder that is when the actual copy and file permission change occurs so...

    After you click the AutoMagic buttons, instead of clicking the activate button for your Root folder BulletProof Mode you would go to the Edit/Upload/Download page and click on the secure.htaccess tab and manually copy the entire contents of the secure.htaccess file (right mouse click, select all, right mouse click copy) into the "Your Current Root htaccess File" text area window overwriting all contents of your Root .htaccess file and then save your changes. File permissions are not changed when you use this manual copy and paste method.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.