WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Complete Uninstall of BPS? (19 posts)

  1. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Okay, I screwed this up and it is most definitely my fault.

    However, at some point, I had .htaccess Control (WP plugin) and Bulletproof Security... And the site just keeps breaking.

    For some reason, if I install a new plugin, no problem. But if I try to activate a plugin that has already been active at some point, the site becomes unusable and I get weird errors. Sometimes server 500 errors... Sometimes other things.

    I installed another .htaccess editor, to see if I could figure out what is going on. Even though BPS is uninstalled, I can see that it is still somehow providing the htaccess. When I go into the editor, I see the BPS code.

    If I use FTP to look at the .htaccess file in my root, this is what I see: (the commenting is from the .htaccess Control plugin, even though I have uninstalled that one too!)

    # WPhtc: Begin Custom htaccess
    RewriteEngine on

    # WPhtC: Protect WP-config.php
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>

    # WPhtC: Protect .htaccess file
    <files ~ "^.*\.([Hh][Tt][Aa])">
    order allow,deny
    deny from all
    </files>

    # WPhtC: Protect comments.php
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*http://sds2.buylifeinsurances.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    But, like I said, if I install an .htaccess editor, I see something else. I see BPS.

    What's really weird is that whatever .htaccess editor plugin I try, it only loads long enough for me to see the BPS code.

    However, then when I try to change it or do anything, I get an error on my page that says "No File Specified" (or something very close to that). The same thing happens if I reinstall BPS. The site breaks. Then I need to remove the plugin via FTP, because I can't get to it any other way... And then that leaves traces of the program... I think.

    I just want to go back to a virgin site and then reinstall BPS...or uninstall it, every trace.

    I am really desperate. I've been trying to figure this out since 4am. Any help is greatly appreciated. I would like to use BPS, but I can't get it back or get rid of it. Thank you in advance.

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    In your case it sounds like you need to download the .htaccess file in your website root folder and then delete it to start all over.

    This is the normal procedure to take BPS out of the equation for testing, but it sounds like you will need to start from scratch by deleting the root .htaccess file.

    To take BPS out of the equation completely for testing.
    1. Make a backup of your .htaccess files using BPS Backup.
    2. Activate Default Mode on the Security Modes page.
    3. Use the Delete wp-admin .htaccess feature on the Security Modes page.
    4. Test your plugin or theme.
    5. Restore your .htaccess files using BPS Restore.
    To completely uninstall BPS you would do the steps 2 and 3 and then just delete the BPS plugin on the WP Plugins page.

  3. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Thank you so much for responding so quickly.

    I just want to make sure I don't break anything again. So, as I understand it: I will download my .htaccess file, just in case. Then I will delete the .htaccess file from my root using FTP.

    Then, I will re-install BPS and start with step 1?

    Thank you so much, again. I'm really sick about this.

  4. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    Yep that is correct. And keep it really simple since BPS is really simple. ;)

    Click the AutoMagic buttons
    Activate all BulletProof Modes

  5. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Okay. I did it.

    Right now, at sdsfamilylaw .com, it is just saying "No Input File Specified." That's it. No server error, nothing.

    Now, I think I am supposed to put the .htaccess back... But I don't think the site will be accessible in any way, until I delete BPS.

    I will put the .htaccess back in the root. And see if that fixes the problem. But I am pretty sure the problem will remain. I need to delete BPS, using FTP in order to get it working again.

    By the way, after I installed BPS, I was able to make the files. After I made the backups, using automagic buttons, I just reloaded the root in another tab and I saw the index page. No problem. Then I clicked on one of my links, and got a 404.

    Then, after the 404, I get the "input file" error. It's almost like it degrades in stages.

    In case you respond quickly again, I will just let the site be down for a little while before I start. Just in case you might have another idea.

    Thank you again. I do appreciate it.

  6. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Okay. I went back to do what I said I was going to do. And, oddly, the site is up. Very odd. I did nothing.

    But, if I click on any links (contact us page, for example), I get a 404 error. It might have something to do with the .html plugin I am using. I will disable that and update this post again.

    Thank you again.

  7. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Okay. All fixed!

    Thank you so much!

    Really, I wouldn't have slept tonight.

    Thank you.

  8. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Okay. Not sure what is happening. The site is down again. I was just inside, and the last thing I did was click the custom code area of BPS and was just reading the description of the fields. Then, I clicked on the dashboard, and I'm getting the No Input File problem again.

  9. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    Most likely your custom permalink structure has a mistake in it. See this post and compare your custom permalink tags and structure to this post >>> http://www.ait-pro.com/aitpro-blog/2304/wordpress-tips-tricks-fixes/permalinks-wordpress-custom-permalinks-wordpress-best-wordpress-permalinks-structure/

    if you have a typo like a missing slash or percent sign then you will see this error.

    And another possibility is that you are not using a valid php handler / php.ini handler

  10. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    No, no typo. This is my custom structure:

    /%postname%.html

    I need to append .html to addresses. I don't really have a way around it. Since I can't follow the recommended permalink structure, would you recommend I remove the plugin?

  11. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    Yep there's your problem. Why do you think you need to append .html to your custom permalink structure? Looking around the Internet I found tons of people getting 404 errors when using .html. ;)

    Some SEO Marketing person many years ago stated that this helped with SEO. It may have many years ago, but i seriously doubt it ever really worked. Google evaluates HTML sites and WordPress sites completely differently and adding .html to your links is not going to fool Google.

    And here is an ancient post from 2005 that tells you what you have to do to use this archaic .html structure >>> http://www.codingrobots.com/blog/2005/12/13/how-to-switch-to-google-optimized-permalinks-in-wordpress/
    And yep you will not be able to use BPS because BPS needs to use standardized RewriteRules in order to work properly. In other words, the .html permalink hack is a no-go if you want to use BPS. ;)

    FYI - this site that has this info posted is NOT using .html permalinks. LOL

  12. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Yes, admittedly, I've been actively involved in SEO since Google appeared on the scene in 1998 and I was a systems analyst reverse-engineering the algorithm.

    When I started using WordPress- a quick change from Expression Engine-- I used the .html permalinks to give Google a sense of "permanence" and it worked great.

    Now, it's just something that I do, because I've always done it. Not sure it helps anymore, but I know it doesn't hurt... So I keep doing it.

    I have acquiesced however. I changed my permalinks and so far, all has been good. Thanks again for all the help.

    It looks like I can't edit my earlier posts. Do you know anyway I can get my domain name outta here?

    Thank you so much.

  13. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    Yep i did some experimentation that was borderline "not cool" SEO tactics with Google many years ago - GreyHat Zone. ;) And did find that mimicking an HTML site did have much more value with Google, but these days what i have found is that you can do all of your SEO completely WhiteHat and still end up with prime real estate on page G1. Since Google has perfected their Algorithm to a point where it is very accurate at detecting the "real" site type then there is actually no need to try and boost ranking by mimimicking - a php site type that meets all of Google's criteria for a high ranking page/post will be a high ranking page/post with the optimum SEO work done to it and the same applies for HTML site type SEO work.

    Not sure what you are asking here?

    It looks like I can't edit my earlier posts. Do you know anyway I can get my domain name outta here?

    Ok so here are the issues you will most likely face. Since you have existing posts out there with your old linking structure then you will have to create .htaccess rules to rewrite those old URL's otherwise you will end up with a lot of legit 404's.
    Take a look at this link to see what kind of .htaccess redirect coding / rules you will need to add.
    http://www.webweaver.nu/html-tips/web-redirection.shtml

  14. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    Thank you.

    I think you misunderstood though-- I meant take my domain address out of this very thread-- as I posted it in the 5th message down. No big deal though. Just wondering if you had editorial control of this thread.

    But seriously, I am so sorry, because my site is now functioning perfectly, since I did everything you told me to...

    But guess what? Now BPS isn't functioning. I think this is how the whole thing started. The whole mess started at this stage.

    When I try to go to any BPS pages (within the dashboard), I get a 500 server error. That's why I deleted the plugin via FTP last time... and everything broke.

    So now I realize, that for whatever reason, BPS just won't work with this site. I wish it did. I love the features.

    I'm so sorry that you've spent so much time on this sir (or ma'am), but I promise to leave you alone if you can help me with this last step. This plugin doesn't like my site or my site doesn't like the plugin.

    Ugh.

  15. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    Nope no control of threads and i have tried requesting that a thread be modified or removed and never had much success with that. I think most WP Moderators are volunteers so trying to monitor millions of threads is a pretty daunting task for volunteer Moderators. ;)

    Typically a 500 error is caused by a typo or invalid .htaccess code in your .htaccess file. Some web host do not allow Options -Indexes to be used and this will cause a 500 error. So you can try commenting that line of .htaccess code out and after that maybe check with your web host and send them a copy of your Root .htaccess file so they can tell you what will and will not work on your web host server.

    Also some web hosts do not allow you to change the file permissions of an .htaccess file to 404. Very few web hosts require that the file permission for .htaccess files is 644, but i have come across about 5 of these web hosts out of 100's.

  16. mgeorge@sdslawaz.com
    Member
    Posted 2 years ago #

    I do think a lot of this has to do with my hosting company and I just signed up with a much better company.

    However, I am still dead in the water, because the only page I get 500 server errors is the BPS page. I can move all around my dashboard, until I get to BPS.

    So is there a clean way to uninstall this, without going through the BPS dashboard?

  17. AITpro
    Member
    Plugin Author

    Posted 2 years ago #

    You can just FTP to your site and delete the /plugins/bulletproof-security folder. Then you would just need to delete the .htaccess file in your Root and wp-admin folder and that is it. If you have other .htaccess code in your Root .htaccess file that you want to keep then download it first before deleting it.

  18. dalewood
    Member
    Posted 1 year ago #

    Hi

    If I want to safely uninstall Bulletproof safely how do I do it

    Kindest regards

    Phil

  19. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic