WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] BPS Alert! An htaccess file was NOT found in your wp-admin folder - H (12 posts)

  1. glenbelt
    Member
    Posted 1 year ago #

    Hi there,

    Someone installed BPS on my behalf to make my wordpress blog more secure. I didn't know how to install it or anything like this, but a few weeks ago I saw from the plugin page that an update was available so I presumed by updating it I wouldn't have to do anything and thought it would continue to work as normal.
    However, whenever I login I get a big warning message at the top of the wordpress dashboard -

    BPS Alert! Your site does not appear to be protected by BulletProof Security...
    BPS Alert! An htaccess file was NOT found in your wp-admin folder.

    I was wondering if anyone could help explain what I need to do to get it back up and running as before?

    Thanks for any help

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    BPS is a very simple plugin to setup and use, but there are a couple of basic steps that need to be done to setup BPS correctly.

    BPS setup steps:
    1. Click the AutoMagic buttons
    2. Activate All BulletProof Modes.
    3. Setup complete.

    BPS removal steps:
    1. Activate Default Mode on the Security Modes page.
    2. Use the Delete wp-admin .htaccess feature on the Security Modes page.
    3. Deactivate and delete BPS on the WP Plugins page.

    Additional troubleshooting & help info:
    http://www.ait-pro.com/aitpro-blog/297/bulletproof-security-plugin-support/bulletproof-security-wordpress-plugin-support/

  3. glenbelt
    Member
    Posted 1 year ago #

    Hi thanks for the reply.
    I've done this (I think) but now it says:

    WARNING! BPS has detected that Safe Mode is set to On in your php.ini file.
    If you see errors that BPS was unable to automatically create the backup folders this is probably the reason why.
    To remove this message permanently click here.

    And then if I scroll down some more, on the security status tab it says:

    An .htaccess file was NOT found in your wp-admin folder.
    BulletProof Mode for the wp-admin folder MUST also be activated when you have BulletProof Mode activated for the Root folder.

    Thanks again for the help..

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Yikes Safe Mode is On. You need to contact your Host and have them take care of this - Safe Mode was deprecated a long time ago (years ago) and should no longer be in use on any Host Servers - it never worked correctly any way right from the get go.

    The safe mode directive cannot be changed using ini_set so you cannot fix that problem by adding an ini_set in your wp-config.php file and can only be set in a php.ini file (safe_mode = Off) or the Server's httpd.conf file or if your Server is DSO configured then you would do add php_flag in your root .htaccess file (php_flag safe_mode = Off).

    I'm now curious about your System Info for your Server. Please go to the System Info page and post this information about your System:
    DNS Name Server:
    Server Type:
    Operating System:
    Server API:
    Multisite:

  5. glenbelt
    Member
    Posted 1 year ago #

    Sure, it is:

    DNS Name Server: ns90.eukdns.com
    Server Type: Apache
    Operating System: Linux
    Server API: cgi - Your Host Server is using CGI.
    Multisite: Multisite is Not enabled

    Let me know the next step - is it simply to contact the host and ask for safe mode to be switched off?

  6. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    eUKHost does not allow custom php.ini files for Shared Hosting so that option is out and since you have CGI as your SAPI you cannot add php_flag to your .htaccess file so that is out.

    Yep you need to contact eUKHost and have them turn off Safe Mode as this will have to be done at the Server in the httpd.conf Server config file or in the php.ini file for your particular Server.

    Also this could be related to a Worldwide problem I am currently researching >>> http://www.ait-pro.com/aitpro-blog/4349/misc-projects/wordpress-tips-tricks-fixes/php5-3-x-php5-4-x-user-ini-file-does-not-work-known-php5-3-x-user-ini-fastcgi-wordpress-zend-issue/

    and in your particular case I have seen a Server revert to an archaic Safe Mode On setting when you try to add your own php.ini file for your website when your Server is running PHP5.3.x. .user.ini files are now used instead of custom php.ini files for PHP5.3.x and up versions now.

  7. glenbelt
    Member
    Posted 1 year ago #

    They've told me that safe mode has now been turned off - so now do I just go through the steps outlined above again?

  8. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Before you try to setup BPS please post this System Information about your website/Server. You will find this information on the BPS System Info page.

    DNS Name Server:
    Server Type:
    Operating System:
    Server API:
    Multisite:

  9. glenbelt
    Member
    Posted 1 year ago #

    DNS Name Server: ns90.eukdns.com
    Server Type: Apache
    Operating System: Linux
    Server API: cgi - Your Host Server is using CGI.
    Multisite: Multisite is Not enabled

  10. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    oops sorry i commented on the wrong thread and asked for your system info again. ;)
    Yep go ahead and click the AutoMagic buttons and activate all BulletProof Modes.

  11. glenbelt
    Member
    Posted 1 year ago #

    Ah wasn't sure if you needed to check to see if anything had changed!

    And thats great, thanks, seems to be working okay now!

  12. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Nope i was juggling comment threads and had a "special" moment. LOL

    Excellent! Glad you got it all sorted out. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags