WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Activation Problems in Admin (13 posts)

  1. dtsviolin
    Member
    Posted 3 years ago #

    Clicking "Activate" in the admin from the PLugins screen caused the following errors.

    Warning: mkdir() expects at most 2 parameters, 3 given in /wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 23

    Warning: chmod() [function.chmod]: No such file or directory in /wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 24

    Warning: chmod() [function.chmod]: No such file or directory in /wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 25

  2. AITpro
    Member
    Plugin Author

    Posted 3 years ago #

    You are running PHP4 on WordPress on your web host. You need to switch that to PHP5. Do this google search for your web host "your web host name PHP5" and you should come across how to enable PHP5 to run on your WordPress installation and also site wide if you want PHP5 to run site wide. Thanks,
    Ed

  3. thefandango
    Member
    Posted 3 years ago #

    I also have this issue, and my php is the latest version.

  4. AITpro
    Member
    Plugin Author

    Posted 3 years ago #

    This is a PHP4 specific error message. PHP5 will generate a different error message so it may appear that you are running PHP5, but actually it is PHP4. Check the BPS System Info tab menu for the version of PHP that WordPress is running on. You will need to check with your particular web host to see what options they offer for choosing your PHP version and if they have an htaccess directive to force PHP5 to run on WordPress then you can just add that directive to Your Current Root htaccess File using the BPS built-in File Editor. Thanks.

  5. riceguitar
    Member
    Posted 3 years ago #

    Hi AITpro,
    Thanks for the tip! That fixed it! Switching my sites to PHP5!
    Regards,
    rice.

  6. thefandango
    Member
    Posted 3 years ago #

    I do apologise, you are correct, my error is

    Warning: mkdir() [function.mkdir]: Permission denied in /public_html/wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 23

    Warning: chmod() [function.chmod]: No such file or directory in /public_html/wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 24

    Warning: chmod() [function.chmod]: No such file or directory in /public_html/wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 25

    This happens when I activate the plugin.

  7. riceguitar
    Member
    Posted 3 years ago #

    @thefandango
    Can you verify the exact version number of PHP that you are using? This problem shouldn't exist if you are infact running the latest version of PHP5.

  8. AITpro
    Member
    Plugin Author

    Posted 3 years ago #

    @ thefandango - This is a PHP5 error message so you do have PHP5 running on WordPress.
    When you activate BPS it automatically tries to create this folder /wp-content/bps-backup. It appears that your folder permissions are set too restrictive to create this folder. mkdir is the command to create a folder or Make a Directory. Change the folder permissions via FTP for the /wp-content folder to 755, which is the standard permissions for that WordPress folder. Then try to activate BPS again. Thanks.

  9. thefandango
    Member
    Posted 3 years ago #

    HI, yep I have the latest stable version of php, I run a VPS and upgraded it a week ago.

    /wp-content is set to 755 and always has been on my installation :-)

    Manually created the directory and its working now thanks - but odd it would not write it when permissions were fine.

  10. AITpro
    Member
    Plugin Author

    Posted 3 years ago #

    I released a later update to BPS that will auto correct any issues with creating the bps backup directory on activation so just download any of the BPS .htaccess files you want to keep as a back up and then uninstall BPS. Before reinstalling BPS FTP to your site and rename the bps-backup folder.
    /wp-content/old_bps-backup
    Uninstalling BPS does not leave your site unprotected. The root .htaccess file and wp-admin .htaccess will not be removed when you uninstall BPS. You will be able to copy any of your .htaccess modifications (if you made any) from your root .htaccess file to the BPS Master .htaccess files using the BPS built-in File Editor. The additional download backup is not necessary, but i prefer to be safe rather then sorry later. Thanks.
    Ed

  11. numaga
    Member
    Posted 3 years ago #

    I get a somewhat similar error message

    Warning: mkdir() [function.mkdir]: Permission denied in /home/piccaz/domains/piccaz.com/public_html/wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 23
    
    Warning: chmod() [function.chmod]: No such file or directory in /home/piccaz/domains/piccaz.com/public_html/wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 24
    
    Warning: chmod() [function.chmod]: No such file or directory in /home/piccaz/domains/piccaz.com/public_html/wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 25

    How to fix this? Is it safe to use the plugin even though I get errors?

  12. AITpro
    Member
    Plugin Author

    Posted 3 years ago #

    The error message is telling you that BPS is unable to create the /wp-content/bps-backup folder because your permissions are set too restrictive for the wp-content folder. The standard, acceptable and secure permissions for the WordPress wp-content folder is 755. On the next version release of BulletProof Security I will include a standard alerting message that will inform someone that they cannot activate and install BPS until they set the correct folder permissions for the WordPress wp-content folder.

    To set the correct folder permissions for the wp-content folder i recommend downloading FileZilla. it is an FTP plugin that allows you to set your folder permissions by entering a numeric value 755.

    FTP to your site with FileZilla, right mouse click on your wp-content folder, click File Permissions and type in 755 in the Numeric Value window, click the OK button. Now activate BPS. Thanks.

  13. AITpro
    Member
    Plugin Author

    Posted 3 years ago #

    And there is another possibility. If Safe Mode is On in your php.ini file then mkdir will not be able to create the folder on BPS activation or when opening the BPS settings page for the first time. I have coded a fix for this possibility and it will be released in BPS .46.1. mkdir and chmod errors will be suppressed on BPS activation. I have added a full HUD display (Heads Up Display) that will go through a check list and report an error message with solution the first time the BPS settings page is accessed.

    For the safe mode on issue - If safe mode is turned on then a Fix button will be displayed and you can just click it to create the folder from within the BPS settings page. This will take care of the issue with the UID compare check that safe mode does. Thanks.

    HUD Checklist
    Check if Permalinks are enabled
    Check if required version of PHP is being used
    Check if IIS and if IIS are URL rewriting prerequisites installed and is BPS compatible
    Check if the BPS backup folder was created and if not display fix button to create the BPS backup folder

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic