WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Toolbar
[resolved] "You do not have sufficient permissions to access this page" (12 posts)

  1. Scott White
    Member
    Posted 2 years ago #

    When attempting to use the toolbar to maintain Buddypress on WPMU (I think it's called WordPress NEtwork or something now, can't recall), I am receiving the error that I do not have sufficient permissions to access the page.
    I have tried with Buddypress 1.5.4 as well as the 1.6-bleeding version from SVN. Also tried using the WordPress built-in installer for the toolbar, as well as manual FTP upload (thinking maybe it was an issue with file permissions).
    Is this an error with WPMU, or is the error related to the toolbar itself?

    I have disabled every single plugin on the site except for buddypress and the toolbar, and the error is still being thrown... enabling debug mode does not seem to be providing any useful information.

    http://wordpress.org/extend/plugins/buddypress-toolbar/

  2. daveshine (David Decker)
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Scott!

    I'm sorry, but it sounds something is wrong with your installation. Do you have latest WordPress 3.3.1 in use? WP has built-in Multisite functionality since WP 3.0 (was summer 2010!) formerly known as WPMU.

    BuddyPress 1.5.4 and 1.6 require WP 3.3+

    Your issue can come from that I guess. Or some user roles/capabilities are missing. This could also be caused from plugins once active that changed user capabilities once they were active...

    To access a BuddyPress admin page you need the proper role/caps - this is fully WordPress and BuddyPress related stuff!

    My admin-intended plugin only does hook menu entries into the toolbar - nothing more and nothing less. It displays only stuff if you have the cap of "install_plugins" - but every admin in WP has that.

    BuddyPress should be installed before so it makes sense - but my plugin doesn't require that.

    I hope this helps a bit.

    Any URL handy?

  3. myom
    Member
    Posted 2 years ago #

    I have the same problem. I´m running the newest stable releases of BP & Wp as a multisite network. The user has the highest role possible (network admin) but the message keep popping up.

    The site is not public though, so I cant send you a link.

  4. daveshine (David Decker)
    Member
    Plugin Author

    Posted 2 years ago #

    @myom:
    I guess you want access in Multisite mode - in this case please wait for the next update of the plugin which will have extended multisite support. I'm on business travel right now but planning update in a week from now.

    I guess the issue is regarding just the admin urls which are regular admin_url and in Multisite network_admin_url. This is not an error of my plugin where at no point (full) Multisite support was stated yet.

    At the moment, you have the only chance to de-activated and wait for my update. If you let it on the server you'll get update notice, otherwise I'll also post here then.

    If you have any feature requests regarding Multisite modus please post here also.

    Thanx for your understanding and patience, though! :)

    -Dave.

  5. myom
    Member
    Posted 2 years ago #

    Hi Dave,

    thank you for your quick and informative answer.

    I will update it asap and am looking forward to using it as it will save me quite some time!

    Thank you for your great work on the plugin and also for the de_DE localization :)

    myom

  6. daveshine (David Decker)
    Member
    Plugin Author

    Posted 2 years ago #

    @all:

    Hi there! I could confirm all your issues and addressed all stuff in my new update version which will release after final testing and documenting new features may today evening or tomorrow (Monday). Thanx for your patience. Just to inform you.

    Thanx, Dave :)

  7. daveshine (David Decker)
    Member
    Plugin Author

    Posted 2 years ago #

    Hi all!

    WOOT, the new and long-awaited new version is finally out!!!
    I needed more time for testing and I think it was worth it - full Multisite support, full support for capabilities, more plugins & themes support... :-)

    I hope all issues are addressed, and you enjoy the update.

    http://wordpress.org/extend/plugins/buddypress-toolbar/

    -Thanks, Dave :)

  8. banarani
    Member
    Posted 2 years ago #

    I just installed buddypress 1.6 (plugin for WordPress) and when I went to settings I get the same error i.e. 'you do not have sufficient permissions to access this page". I then deactivated and deleted buddypress, bbpress, the toolbar adn re-installed buddypress plugin 1.6, I also deleted all pages called Forum, including permanently deleting from trash, yet the error persists. I am the only admin for my site (single site on hostgator). I have wordpress 3.4.1 (theredplane.com).

    Any suggestions will be much appreciated. thanks in advance!

  9. banarani
    Member
    Posted 2 years ago #

    Update: I activated the Jetpack and the error went away! (at least I think it was due to the jetpack activation, because everything else I tried did not work, and it was the single other thing I did. So I guess it was the Jetpack activation. In any case, great!

  10. daveshine (David Decker)
    Member
    Plugin Author

    Posted 2 years ago #

    @banarani:
    Thanks for your feedback and for trying out/using my plugin!

    The Jetpack issue sounds strange and I will test at home if this also effects my plugin...

    Great you got it to work again!

    -Dave :)

  11. banarani
    Member
    Posted 2 years ago #

    Dave, Thanks for replying!
    I am pretty sure the issue is with Buddypress itself or how Buddypress affects WordPress and not the Buddypress Toolbar.
    I have seen this issue elsewhere on the forums and there it had to do with only Buddypress.
    cheers
    Bana

  12. juggledad
    Member
    Posted 1 year ago #

    with BP 161 if you click onthe 'setting' link on the plugin page you get the permission error. You first have to click on the 'Dashboard' tab and you will see a 'BuddyPress Setup' link that does the initial setup, then you can use the setup button on the plugin page.

    Having that 'initial' setup link in under the Dashboard' tab is a bad idea espically since it goes away after you fires use it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic