WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Multilingual
v1.4.0 broke WPML Language Selector (18 posts)

  1. prock13
    Member
    Posted 1 year ago #

    I'm using WordPress 3.4.2 MU with BuddyPress 1.6.1 and WPML 2.6

    Everything seemed to be ok until I upgraded to Buddypress Multilingual 1.4.0. Now my language selector does not change the languages correctly.

    When switching languages, the URL it is trying to change to, does add the language directory as it should but it is not showing the post/page name in the alternate language.

    For example if you are in : http://www.domain.com/postname and switch to the other language you get http://www.domain.com/es/postname but the postname is still showing in the original language.

    http://wordpress.org/extend/plugins/buddypress-multilingual/

  2. bschmidttraub
    Member
    Posted 1 year ago #

    Same issues here!
    I'm using exactly the same components like prock13 and have the same problem. I'm working on a two language site (german english)and the WPML Menu doesn't translate the slug.

    For example http://something.com/aktivitaeten comes to http://something.com/en/aktivitaeten not to http://something.com/en/activites how it should be.
    The funny thing is that it works anyway but http://something.com/en/activites doesn't work.

  3. prock13
    Member
    Posted 1 year ago #

    Unfortunately I am not getting any help and it's still not working. I have a site for a major client in production and not working...

  4. prock13
    Member
    Posted 1 year ago #

    bschmidttraub....let me ask you...

    When you are in the WordPress admin and go to Settings -> BuddyPress and select the pages tab.

    Are you able to switch languages and select the pages for register, activate, members, etc?

    I can do it for one language, but when I switch to the other language it seems to overwrite the previous language selection. So it's like I can only have the pages defined in only language a ta time.

  5. bschmidttraub
    Member
    Posted 1 year ago #

    hi prock13,
    yes -same for me. But I'm not shure if the plugin is meant to work this way. For me it works if I manualy edit the slug in second lang to be the same as the main language.

    I know it's not ideal but it works.

    Another possible solution I found here: http://wpml.org/forums/topic/bpml-with-buddypress-1-6/
    But it deals with bpml version 1.3. I haven't testet it but maybe its a way out to manualy code the language switcher in the theme.

  6. prock13
    Member
    Posted 1 year ago #

    Hmm...so in the page definition you just have the slugs named the same for both languages? Let me try that. But I think the reason it works is cause the bug in the plugin is that it does not change the name of the page. Like in your example: http://something.com/aktivitaeten comes to http://something.com/en/aktivitaeten not to http://something.com/en/activites

    I'm actually already doing something like in that post with the exception that I am not creating a UL list. I'm just listing the languages...My code looks like this:

    function icl_post_languages(){
    $languages = icl_get_languages('skip_missing=1');
    if(1 < count($languages)){
    foreach($languages as $l){
    if(!$l['active']) $langs[] = ''.$l['native_name'].'';
    }
    echo join(', ', $langs);
    }
    }

  7. bschmidttraub
    Member
    Posted 1 year ago #

  8. jujiso
    Member
    Posted 1 year ago #

    Hi bschmidttraub,

    I have the same issue. I have tried to get support form WPML but still waiting. Have you already solved this?

    If so, I'd appreciate some help.

    Danke! ;)

    Julio

  9. bschmidttraub
    Member
    Posted 1 year ago #

    Hi Julio,
    no, not at all, the issue is still unsolved. But we actually do not need buddypress for this project.
    But sorry - no news to that subject.

    Bitte ;-)

  10. jujiso
    Member
    Posted 1 year ago #

    Did you change to other software? I just visited your site (the one you published in the WPML forum) and looks like the issue is still there, isn't it?

  11. abshkd
    Member
    Posted 1 year ago #

    i was gonna buy wpml. i see no author support for this awesome plugin. If its not perfect I will wait. saved my money. thanks for reporting the issue hope he fixes it. I dont mind paying if i can help out the spanish members of my bp forums

  12. netigate
    Member
    Posted 1 year ago #

    same problem here

  13. netigate
    Member
    Posted 1 year ago #

    use version 1.3 instead. it works. just tested it

    http://wordpress.org/extend/plugins/buddypress-multilingual/developers/

  14. bschmidttraub
    Member
    Posted 1 year ago #

    thank you netigate!
    will try it

  15. netigate
    Member
    Posted 1 year ago #

    just an addition. 1.3 works with the groups, but not with the wall/activity of BP 1.6 and WordPress 3.5.

  16. prock13
    Member
    Posted 1 year ago #

    This still does not work for me even in 1.3...

  17. Dominykas
    Member
    Posted 1 year ago #

    Hi all,

    We fixed this bug in the latest version (v1.4). Please update it. However, if you'll find an issue somewhere please post it in our support forum - http://wpml.org/forums/forum/english-support/ . It's better for us to track and resolve them there.

    Thanks,
    Dominykas

  18. netigate
    Member
    Posted 1 year ago #

    it seems to be all working now with bp 1.6.4

    nice job!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.