WordPress.org

Ready to get started?Download WordPress

Forums

rtMedia for WordPress, BuddyPress and bbPress
[resolved] [Plugin: BuddyPress Media Component] documentation, support, upload video and kaltura (39 posts)

  1. okso
    Member
    Posted 2 years ago #

    Hi, I have an issue with video upload on Media 2.0, - 'the MP4 file you have uploaded is using an unsupported video codec. Supported video codec is H.264'. I subscribed to the forum but it says that I can't post at the moment. Can you tell me how I can get some help with this issue, either a pointer to help resource or paid support. Thank you in advance. David

    Additional notes: wp3.4.1 multisite with Buddypress 2.6
    Image upload works OK, H.264 fails
    I've tried to gather from documentation if Kaltura Community Edition (CE) is still required with BuddyPress Media Component v2.0 but I cannot find any concise documentation for this latest version. *I do not get any Kaltura partner fields in wp-admin/network/admin.php?page=bp-media-settings

    http://wordpress.org/extend/plugins/buddypress-media/

  2. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    'the MP4 file you have uploaded is using an unsupported video codec. Supported video codec is H.264'

    We currently have added only the MP4 file support with H.264 codec; the file you are uploading must be using some other codec, so its not working. The reason we did that is because HTML5 is compatible with that codec only.

  3. gajanansapate
    Member
    Posted 2 years ago #

    Hello David.

    The current version is independent of KalturaCE, you need not require Kaltura Partner ID to use this plugin.
    We are in process of creating the developers' documentation, it will be soon added on website. The FAQs are updated on website.

    You will get all dedicated technical free support on our support forums OR we will also offer the paid services as per your requirements.

    Cheers!
    -Gajanan

  4. okso
    Member
    Posted 2 years ago #

    Hi @Gagan Deep Singh, I understand it must be H.264. The 1st attempt was via Quicktime transcode, I then did another render using MPEG Streamclip's H.264 iPod transcode. I've also added these types to my media support in wordpress 'jpg jpeg png gif mp3 mov avi wmv midi mid pdf mp4'. This is the fail message I get the 'MP4 file you have uploaded is using an unsupported video codec. Supported video codec is H.264'. Here's a screenshot of file info: http://screencast.com/t/1upPOWLau

    Any ideas appreciated as to what I can try next?

    @gajanansapate, thanks for clarifying the KalturaCE spec.

    Thank you. David

  5. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    @okso: can you please provide me with the MP4 you have used to upload(for debugging), since I am unable to get any such error with correct codec. I am using a Windows machine and using AnyDVDConverter for encoding the files. I've tested the plugin with following formats which are working:

    • Video:H.264 Audio:MP3
    • Video:H.264 Audio:AAC
    • Video:H.264 No Audio

    and found the plugin to be working fine with these.

  6. okso
    Member
    Posted 2 years ago #

    ah, I'm on OSX 10.6.8
    here's my test file: https://dl.dropbox.com/u/3021571/ArtjazH264.mp4

  7. okso
    Member
    Posted 2 years ago #

    Hi Gagan Deep, did the mp4 work for you, do you need anything from me?

  8. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    Thanks for providing me with the file, and sorry for the delayed response(was caught up in work), you don't need to do anything, the library we used to check the file info is acting a bit weird and giving false negatives, so we'll be changing that library in a day or two and will update the plugin. Then all your MP4 files will work. :)

    Here's a bit elaborated description of the issue and how we're gonna solve it http://rtcamp.com/blog/buddypress-media-video-upload-issues/

  9. okso
    Member
    Posted 2 years ago #

    Hi Gagan Deep, thanks for the update.

  10. maurice-wingfield
    Member
    Posted 2 years ago #

    Thank you for the answer, Gagan. This plugin promises exactly what I need. I'll wait for the update.

  11. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    Have used getID3 php library for resolving this issue. Update the plugin and it will be resolved.

  12. okso
    Member
    Posted 2 years ago #

    Success! Thank you.

  13. okso
    Member
    Posted 2 years ago #

    hi, success on small files but trying to upload 62 meg mp4 via getID3 php library I get Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 12845056 bytes) in /wp-content/plugins/worker/init.php on line 123 (managewp worker plugin). With worker plug disabled it fails on client side without any reporting. I'll start to dig into this but if you have any leads I'd appreciate a heads up. I have 128M in dedicated server php ini.

  14. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    @okso: I'll look into it in a virtual machine with the specs you gave, thanks for reporting, will see if there's anything we can do to help.

  15. okso
    Member
    Posted 2 years ago #

    also getting wp debug when I load /members/member-name/images or(video)or(audio)/: Notice: Undefined property: BP_Media_Host_Wordpress::$post_type in /wp-includes/post.php on line 819

  16. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    @okso: Can you please tell me the following things->

    1. Buddypress Version you are using.
    2. Other plugins you have activated on your site(with versions).
    3. What is the configuration of your server(RAM, apache/nginx version+configuration and php.ini file would be great)

    Also, I work only with debug mode enabled, I never saw that error.

  17. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    @okso: I tried to re-create the memory problem you faced, I set up a ubuntu server with 256 MB RAM and 1 core, used Apache2(2.2.14) restricting the memory size to be 128MB and uploaded a 350MB file, it didn't got the error even then, since the getID3 library uses only a few KBs of info(I looked into it in detail) and do not actually parse the entire file, I don't think its possible for it to cause any Memory Overflow problem. Still I'll test a few more times with different configurations, in the hope I might find your error.

  18. okso
    Member
    Posted 2 years ago #

    hi Gagan Deep, can I dm you with a link, will it be easier for you to see whats going on this way? d

  19. okso
    Member
    Posted 2 years ago #

    PHP version is 5.3.3
    Parallels Plesk Panel v11.0.9_build110120608.16 os_CentOS 6
    OS CentOS 6.2 (Final)
    httpd 2.2.15-15.el6.centos.1
    phpini 128M
    post_max_size/upload_max_filesize 128M
    (max_execution_time/max_input_time) not set *what do you recommend?
    safe mode off

    WP 3.4.1
    BP 1.6.1
    BBPress 2.1.2

    WP debug: Notice: Undefined property: BP_Media_Host_Wordpress::$post_type in /wp-includes/post.php on line 819

  20. okso
    Member
    Posted 2 years ago #

    WP debug on upload of small file reporting BP Media 'Success', Notice: Trying to get property of non-object in /wp-includes/ms-blogs.php on line 703

    *this is the root site on multisite setup

  21. okso
    Member
    Posted 2 years ago #

    WP debug on /videos/watch/1106/ OK
    WP debug on /members/membername/videos/ Notice: Undefined property: BP_Media_Host_Wordpress::$post_type in /var/www/vhosts/picnicvillage.com/httpdocs/wp-includes/post.php on line 819

  22. okso
    Member
    Posted 2 years ago #

    In admin bp activity /wp-admin/network/admin.php?page=bp-activity I see [bp_media_content id="1106"] with view activity url 'http://bp_media_urlid%3D1106/'

  23. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 2 years ago #

    @okso: Thanks for providing with these reports, about the admin part, its changed since BuddyPress 1.6 and I guess we need to add a way so that activities of bp-media can be easily managed from backend.

    About the multisite thing, I guess I need to check it more thoroughly in a multisite environment, which I'll be doing in the morning(its 1am IST) I'll keep you updated on the results and fixes we'll make.

  24. okso
    Member
    Posted 1 year ago #

    Hi Gagan, not to trouble you, I just wondered if you'd made any progress on this.

  25. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 1 year ago #

    @okso: Buddy, I had setup a multisite installation(subdirectory structure) and tried to replicate your problem but never got the Notice message you mentioned.

  26. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 1 year ago #

    @okso: Try it with the new release of the plugin and let us know if it still gives the same error.

  27. okso
    Member
    Posted 1 year ago #

    Hi, thanks for update.

    Network admin bugs are still there http://screencast.com/t/AeYUMP0oL3v

    Also, repeated test with 65Mb.mp4, the connection reset problem occurred again.

  28. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 1 year ago #

    The screenshot you've given is showing the content of the activity which basically is a shortcode as of now. In our next release we'll be making the content static then you'll see audio, video or image tag instead of those shortcodes.
    Also here's how I tested it:
    Installed the Multisite with subfolder structure.
    Installed BPM on the main whole network.

    I guess I need to test it by enabling it only on a child site instead of whole network and see if it works or not.

  29. okso
    Member
    Posted 1 year ago #

    Hi Gagan, would you like direct access to my site? If I go for smaller files circa 15Mbs I can get it to complete. As soon as the file size gets bigger I get the 'connection reset' error. Does this infer some intricacy with holding the connection open longer? I have Rahul's mail, shall I set up a user for you?

  30. Gagan Deep Singh
    Member
    Plugin Contributor

    Posted 1 year ago #

    @David: The thing is, connection reset happens depending upon the configuration of your server's php.ini file
    look for these values:
    max_execution_time = 300000
    max_input_time = 300000
    memory_limit = 256M

    Increase the timeouts to the point where you can upload that 65 MB file to the server with your internet connection(eg, 2MBPS internet connection will take around 300 seconds).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags