WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Links
Shadowbox not working (14 posts)

  1. mike365
    Member
    Posted 3 years ago #

    On the most current version 3.1 the shadowbox effect to play videos does not work. Im sure its a simple fix, but when you click the play button, the shadow comes up but the videos (YouTube) does not play.

  2. primated
    Member
    Posted 3 years ago #

    I am experiencing this as well.
    Can anyone think of a workaround?
    Sometimes I hate WordPress upgrades!

    Thanks

  3. Jamessy
    Member
    Posted 3 years ago #

    Same here. Any fixes yet?

  4. Jamessy
    Member
    Posted 3 years ago #

    Just added this to the line 49 of the global.js file http://wordpress.org/support/topic/plugin-buddypress-links-shadowbox-not-working?replies=3
    and it worked

  5. Cam
    Member
    Posted 3 years ago #

    You added a link to this post into your global.js file?

    Or is this a mistake?

    I'm having this problem and I'd love to find a fix.

  6. primated
    Member
    Posted 3 years ago #

    I found a fix for my problem.
    I went into the settings and keep trying different Javascript Library's.
    Then it worked. Mine works using JQuery.
    I hope this works for everyone else.

    Be Well

  7. Cam
    Member
    Posted 3 years ago #

    Which settings; where did you go to find the settings options?

  8. Jamessy
    Member
    Posted 3 years ago #

    Sorry not sure why I pasted that link in, late night!

    Right the main problem was that the containing div was hidden, so I set it to show using jquery

    jQuery('div_id').show()

    and it worked. You should be able to add this to the template file or the global.js which is the the plugin folder

  9. primated
    Member
    Posted 3 years ago #

    Look for Shadowbox JS under setting in the left of the dashboard.
    Click on that and it will open up the Shadowbox control panel.

  10. primated
    Member
    Posted 3 years ago #

    Jamessy,
    You don't have to mess with the code.
    You can choose that setting in the Shadowbox JS control panel

  11. Cam
    Member
    Posted 3 years ago #

    Thanks guys.
    I did several things and it began to work.

    The thing I found that probably did it for me was updating jquery.colorbox-min.js to the latest version, since the wordpress update probably replaced their version.

    @primated This particular site of mine doesn't use the shadowbox plugin, therefore that is why I couldn't find these settings. Thanks for clarifying.

    @Jamessy I tried your fix with the update first and it worked, and then for clarifications sake, I removed it and it still worked. I placed it back because it doesn't seem to cause any harm and it may help with functionality.

    So for everyone, another fix is to update jquery.colorbox-min.js to the latest version which is available at http://colorpowered.com/colorbox/.

    Thanks for pointing me in the right direction.

  12. Cam
    Member
    Posted 3 years ago #

    What I meant to say is --Wordpress updated their jquery and made this colorbox version invalid.

    :)

  13. @mercime
    Volunteer Moderator
    Posted 3 years ago #

    Cam, thanks for sharing your solution at the BuddyPress BP Links forums
    http://buddypress.org/community/groups/buddypress-links/forum/topic/does-this-plugin-work-with-wp-3-1/

    Cheers.

  14. Cam
    Member
    Posted 3 years ago #

    You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic