WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: BuddyPress Groupblog] Help Needed - Please (6 posts)

  1. gus-f2c
    Member
    Posted 4 years ago #

    Installed Group Blog, and set one blog up, however following a few errors I deactivated the plug-in and deleted the blog.

    Was trying to re-install, and setup the blog for the same group as above, but now I get no name or link for the blog, or the ability to create new details.

    Does anyone know of anyway I can get the blog back so that it can link into the Blog settings within the Group?

    Many thanks in advance.

    G

    http://wordpress.org/extend/plugins/bp-groupblog/

  2. Mariusooms
    Member
    Posted 4 years ago #

    Thanks for pointing this out Gus...what we need to do is some cleanup when a site admin deletes a blog. Your group in question still has meta data in groupmeta that links it to the blog that no longer exist. You could go in your database and delete the meta keys responsible.

    Let me know if you have access to your db and you need help with this.

    In the next version we will make sure we clean up after making a mess :)

  3. gus-f2c
    Member
    Posted 4 years ago #

    Hi Marius

    Looking at trying to clear the db up now.

    Fairly new to all this, so is it just the groupmeta table that needs to be cleared up?

    Many thanks

    Regards

    Gus

  4. Mariusooms
    Member
    Posted 4 years ago #

    Hi Gus, first please make sure you update the plugin to 1.4.4 first.

    After that see if there's still a blog in your site admin that does not look right (doesn't have the right, or even no, url) and needs deleting. Delete that blog (OFF COURSE MAKE SURE IT IS A WRONG BLOG THAT WE CREATED AND CAN BE DELETED, OTHERWISE DO NOT DELETE IT) and make sure to save the admin settings of the groupblog (this is important, even if you did not delete a blog). In most cases this should be enough, otherwise follow instructions below.

    If you have access to your db, find the table wp_bp_groups and browse it to find the right id of the group with the error in question. Remember its id. Now browse the table called wp_bp_groups_groupmeta and find all 'meta keys' that match your group_id. Since you've deleted the blog that was linked to it, you need to now delete the meta keys we failed to delete for you. Select the meta keys which start with groupblog_ for the group_id in question and delete them.

    You should now be able to go back to your group in BuddyPress and in your group blog admin you can select an existing, or create a new, blog.

    If any of this does not make sense or you have additional questions let us know.

    Sorry again for this terrible bug, but atm we can only rectify it by doing a manual delete.

    Regards,

    Marius

  5. gus-f2c
    Member
    Posted 4 years ago #

    Hi Marius

    Absolutely Quality!

    Many thanks for your time and trouble!

    Greatly Appreciated!

    Regards

    Gus

  6. Mariusooms
    Member
    Posted 4 years ago #

    Glad to be of help, especially if it works! If it is not to much trouble feel free to leave your rating :)

Topic Closed

This topic has been closed to new replies.

About this Topic