WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: BuddyPress Groupblog] Error when adding group (10 posts)

  1. tmcandle
    Member
    Posted 4 years ago #

    Here are the errors, but the group was created. I had to go back to the previous page and then could proceed with the error saying that a blog already existed....

    Warning: Invalid argument supplied for foreach() in [...]/html/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php on line 37

    Warning: Cannot modify header information - headers already sent by (output started at [...]/html/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php:37) in [...]/html/wp-content/plugins/buddypress/bp-groups.php on line 507

    Warning: Cannot modify header information - headers already sent by (output started at [...]/html/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php:37) in [...]/html/wp-content/plugins/buddypress/bp-groups.php on line 508

    Warning: Cannot modify header information - headers already sent by (output started at [...]/html/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php:37) in
    [...]/html/wp-includes/pluggable.php on line 865

    http://wordpress.org/extend/plugins/bp-groupblog/

  2. still giving
    Member
    Posted 4 years ago #

    No fix but I can confirm a similar fault

    Warning: Invalid argument supplied for foreach() in example.com/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php on line 37

    Warning: Cannot modify header information - headers already sent by (output started at example.com/wp-content/plugins/bp-groupblog/bp-groupblog-admin.php:37) in example.com/wp-includes/pluggable.php on line 865

    The blog is actually made but during the make up the site whites out to the error message above.

    Shame ...

    I have seen similar errors with pluggable.php in other installs.

    Line 865 relates to fastcgi and IIS servers.

  3. still giving
    Member
    Posted 4 years ago #

    Created blogs also do not turn up in the Blog Listing.

  4. joafruit
    Member
    Posted 4 years ago #

    I've thoroughly tested the plugin and it seems to be working **perfectly** with one big error only - my users can't post / edit their posts to the blog. Only the administrator the group can access the group blog dashboard and post / edit posts.

    Looking forward to the next update which fixes this.

    Joa

  5. Mariusooms
    Member
    Posted 4 years ago #

    This error is caused by moving back to previous pages while creating the group. Since the blog is already created this is causing an unintended error.

    We need to debug this and see if we can find a better approach.

    @joafruit, see you other post for an explanation on your problem.

  6. Mariusooms
    Member
    Posted 4 years ago #

    This is fixed now as per 1.2.4.

  7. 1stAngel
    Member
    Posted 4 years ago #

    Everything is filling out ok on the form but nothing saves. Go to blog on group menu takes you back to the front page of the site. Then when you go back to the group the link is gone and nothing saved.

  8. Mariusooms
    Member
    Posted 4 years ago #

    What version of wpmu, bp-groupblog and buddypress are you using? what other plugins have you installed.

    Can you reproduce the issue here: http://sandbox.ywamcloud.com

    It is our demo site for various plugins we work with. Feel free to test and break stuff there. This site is running wpmu 2.8.6, bp-groupblog 1.3.1 and buddypress 1.1.3.

    Hope that helps.

  9. SilkchenGermany
    Member
    Posted 4 years ago #

    Hello, I am using

    WordPress MU 2.9.1.1 and
    Buddypress latest version

    also bp contents and
    role scoper 1.1.6

    everything just installed, nothing changed/adapted yet.

    When I choose groups I see my groups and when I click on one I receive the following error:

    Fatal error: Call to undefined function bp_groupblog_is_blog_enabled() in /hp/bg/ab/zq/www/wp-mu/wp-content/plugins/bp-groupblog/bp-groupblog.php on line 127

    Groupblog Settings gives me the folowing error:
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'bp_groupblog_management_page' was given in /hp/bg/ab/zq/www/wp-mu/wp-includes/plugin.php on line 339

    I can create a new group with name, settings (public, enable wire comments) and avatar. After inviting friends I click on finish and receive this error:
    Fatal error: Call to undefined function bp_groupblog_is_blog_enabled() in /hp/bg/ab/zq/www/wp-mu/wp-content/plugins/bp-groupblog/bp-groupblog.php on line 127

    The group is there when I go back to the dashboard/blog page.

    What did we do wrong?

  10. Mariusooms
    Member
    Posted 4 years ago #

    Upgrade to bp-groupblog v1.4

Topic Closed

This topic has been closed to new replies.

About this Topic