WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Group Email Subscription
Nothing saves (15 posts)

  1. slips111
    Member
    Posted 2 years ago #

    Whether I try to save e-mail options through the /groups page or by clicking 'E-mail Options' in individual groups, preferences are immediately lost.

    The other issues I've got are mostly cosmetic, but this renders the plug-in worthless for me. It's gone awfully quiet in here, but I'd happily buy a coffee for anyone who could help me work through this. Or if this plug-in is flagging, does anyone know of another one? My users are missing out on too much content by having to actively click the 'Groups' tab to keep up.

    http://wordpress.org/extend/plugins/buddypress-group-email-subscription/

  2. dabeebe2000
    Member
    Posted 2 years ago #

    I have the same experience, or close. But at the root of all the groups I can change the setting easily, and when above the forum, but if they go into email settings it doesn't work. I am on wordpress 3.2.1 and buddypress 1.5.1. I am still finding this plugin invaluable, but would love to get this issue fixed. I believe I have my users trained to update at the all groups they are a member of view thankfully though.

  3. Boone Gorges
    Moderator
    Plugin Author

    Posted 2 years ago #

    I can't reproduce either of these problems. Are you using custom themes? Do you get any error messages? Do you have access to your PHP error log, where I might get more detailed information about the problems?

  4. dabeebe2000
    Member
    Posted 2 years ago #

    I am using the Social theme from WPMU. Looks like I don't have error logging for PHP turned on, so I will get that going.

  5. slips111
    Member
    Posted 2 years ago #

    I'm using Suffusion theme, and unfortunately I can't (figure out how to) get an error log, though there are no relevant plugin errors at validator.w3.org, for whatever that's worth. As with my other forum post, the site is here: http://goo.gl/GcXnx. 'test' and 'test' will log you in, though the plugin isn't enabled at the moment because it's just confusing people. I'll put it up for a day if you give me a signal here. Also, the site is slightly, gently NSFW....

    Thanks.

  6. rraymer
    Member
    Posted 2 years ago #

    Same problem here.
    Email options not saaving
    From the error log:
    26-Nov-2011 06:46:02] PHP Warning: Division by zero in /home/catalent/public_html/members/wp-content/plugins/bp-album/includes/bpa.template.tags.php on line 72

  7. slips111
    Member
    Posted 2 years ago #

    For the record, and for whatever it's worth, the 2.9.6 update didn't fix this for me.

  8. Boone Gorges
    Moderator
    Plugin Author

    Posted 2 years ago #

    validator.3g.org errors will only say what happens on the front end of your site; this problem is on the back end.

    rraymer - That problem doesn't seem like it should be related - it's a BP Album issue.

    Not sure how to troubleshoot this issue. It's nearly impossible without having access to some real debugging, which is hard when I can't reproduce the issue on any of my own installations. If one of you is familiar enough with PHP to do some strategic var_dump() or print_r() statements, it would be quite helpful.

  9. king76
    Member
    Posted 2 years ago #

    My hack :

    1. Edit "bp-activity-subscription-functions.php" file
    2. Change if ( $bp->current_component == 'groups' && $bp->current_action == 'notifications' ) { by if ( $bp->current_component == BP_GROUPS_SLUG && $bp->current_action == 'notifications' ) {
    3. Comments this line bp_core_redirect( wp_get_referer() );

    Can you testing ?

  10. Boone Gorges
    Moderator
    Plugin Author

    Posted 2 years ago #

    king76 - Thanks very much for posting this. That gives me a very clear sense where to look. Working on a fix.

  11. Boone Gorges
    Moderator
    Plugin Author

    Posted 2 years ago #

    king76's message made me realize that the problem is probably that you're all using a groups slug other than 'groups', and the plugin wasn't being generous enough in this spot to account for it.

    I've just tagged version 2.9.7 of the plugin, with a fix for this problem. Let me know if it helps.

  12. dabeebe2000
    Member
    Posted 2 years ago #

    You guys rock! I love well supported plugins. I don't see it on the plugin site yet, but once I do I will test and get back to you. I assume I am looking in the right place - http://wordpress.org/extend/plugins/buddypress-group-email-subscription/changelog/

  13. king76
    Member
    Posted 2 years ago #

    Yes I use Buddypress in french and I have changed SLUG by "groupes".

    And for the other line ? "bp_core_redirect( wp_get_referer() );", I have a blank page if I don't comment this line.

    Thank You

  14. dabeebe2000
    Member
    Posted 2 years ago #

    Thanks, changed worked perfectly!

  15. slips111
    Member
    Posted 2 years ago #

    The new update works here too (though 'groups' was my slug). Thanks! Still having problems with a hidden 'Get E-mail Updates' box, but I'll keep that in its own topic. Is there a link where I can contribute? Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic