WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Group Email Subscription
default mail settings voor group admin (creator) always none? (6 posts)

  1. kalonly
    Member
    Posted 2 years ago #

    Great plugin!
    If a user creates a new group and selects f.i. DIG as the Email Subscription Defaults, every new user get the DIG status automatically (as it is supposed to).
    However, the creator of the group (the group admin) gets NONE as his setting for mails at the moment of creation of the group.
    Is it possible to change this in such a way that the creator of the group gets the same mail status as the selected Email Subscription Defaults (DIG in this example) automatically?

    http://wordpress.org/extend/plugins/buddypress-group-email-subscription/

  2. thosch
    Member
    Posted 2 years ago #

    I have a similar question:
    How can I change the default to all new created groups getting daily emails?

  3. thosch
    Member
    Posted 2 years ago #

    I found a solution to my own question :)
    In the file bp-activity-subscription-functions.php change 'no' in line 791 - "else if ( $setting == 'no' && !$stored_setting )" according to following:
    ‘no’ - No Email
    ‘sum’ - Weekly Summary Email
    ‘dig’ - Daily Digest Email
    ‘sub’ - New Topics Email
    ‘supersub’ - New topics are sent as they arrive

    Thanks for a great plugin!!

  4. kalonly
    Member
    Posted 2 years ago #

    your solution sets the defaults for the members of the group, NOT for the group admin.

  5. chrisvallleyoc
    Member
    Posted 1 year ago #

    This should clearly be a setting for the plugin. Anyone figure out a fix?

  6. Vernon Fowler
    Member
    Posted 1 year ago #

    Without email updates from BuddyPress, members are likely to be drowned in updates from other social networks they also belong to. As such, this plugin provides crucial functionality to our BuddyPress site and hence why I love this plugin.

    I've also been observing this problem in my installation for a while and would greatly appreciate a fix. Keep me posted. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags