WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: BuddyPress Gifts] Few Errors (6 posts)

  1. Jess
    Member
    Posted 4 years ago #

    The notifications bar shows you have a 'Hi 5' - clicking it takes you to a 404 page
    http://tinypic.com/r/3d9o8/5
    http://tinypic.com/r/o9ha45/5

    In a profile it says: Username' Gifts
    it should say: Username's Gifts

    http://tinypic.com/r/14dzlgg/5

    Gift position wrong / 'Send Gift' button wrong (IE 7/8/FF)

    After sending the gift it says 'Gifts was sent' - It should be 'Gift was sent'

    In Activities section, it shows: User1 send giftname to User2
    It should be: User1 sent a giftname to User2

    The same problem is in members/user/gifts

    If a user has no gift, it shows:You still don't have any gift yet!
    It should be:You still don't have a gift yet!

    That will be all, for now. Good luck =)

    http://wordpress.org/extend/plugins/buddypress-gifts/

  2. warut
    Member
    Posted 4 years ago #

    thanks for report jesstar.

    It will be fix in next version.

  3. bondageradio
    Member
    Posted 3 years ago #

    upgraded to v3.0.3 of wordpress (now 3.0.4) and plugin no longer works.

    this was a popular addon for my users, but it's now non functional.

    please help

  4. jgomula
    Member
    Posted 3 years ago #

    I would love for this plug in to work, but instead it says this:

    Your Gifts

    Fatal error: Call to undefined function bp_has_activities() in /home/content/j/g/o/jgomula1/html/play/wp-content/plugins/buddypress-gifts/includes/templates/gifts/screen.php on line 128

    And my nav. bar at the top disappears :(

    All updated plugins and newest wordpress version.

  5. yallways
    Member
    Posted 3 years ago #

    well can already tell you that you can fix the part about the high-five by editing line 626 on buddypress-gifts/includes/bp-gifts-core.php

    Still not sure how to fix the link though. looking into that. But it's not my plug-in so if you do fix the link... keep in mind that an update will undo that fix unless the update includes the same link you put there.

    Could someone tell me how to fix that link so it dont go to "Page Not Found"?

  6. yallways
    Member
    Posted 3 years ago #

    ok here the fix for that.....

    line 626 on buddypress-gifts/includes/bp-gifts-core.php

    Change this line...

    return apply_filters( 'bp_gifts_single_newgifts_notifications', '' . sprintf( __( '%s sent you a gift!', 'bp-gifts' ), $user_fullname ) . '', $user_fullname );

    to this

    return apply_filters( 'bp_gifts_single_newgifts_notifications', 'loggedin_user->domain . $bp->gifts->slug . '/" title="' . __( 'Multiple gifts', 'bp-gifts' ) . '">' . sprintf( __( '%s sent you a gift!', 'bp-gifts' ), $user_fullname ) . '', $user_fullname );

Topic Closed

This topic has been closed to new replies.

About this Topic