WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Courseware
[resolved] Installing Courseware on Multisite (12 posts)

  1. professor_king
    Member
    Posted 1 year ago #

    hello i have a multisite installation that i just installed buddypress and buddypress courseware on. the problem is i am showing no courseware navigation on my network root site and am completely unable to use it. i only see buddypress under settings tab, but nothing for courseware at all. i am using the default buddypress theme with the latest versions of buddypress and courseware. please help me! I dont believe its a server side issue but i want to make sure

    http://wordpress.org/extend/plugins/buddypress-courseware/

  2. Stas Su?cov
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure how great is BuddyPress support for MultiSite. Last time I checked it was pretty poor, that's why I never advised using Courseware in a MultiSite environment.

    Can you confirm it's only an issue with MultiSite?
    Thanks.

  3. I can confirm.

    I'm not sure why you would not check for multisite, since Buddypress was designed for multisite to start with.

    I'm getting an error on activation. The plugin is checking for the BP settings pages where they would be in a single site installation.

    Buddypress in multisite is network activated. There is no choice to activate it any other way.

  4. professor_king
    Member
    Posted 1 year ago #

    thanks for the input stas. i was able to get courseware working after realizing that the manual was a little outdated. there is no settings for courseware in my admin back-end, but i am able to work the software from the front end under buddypress groups. i would like to mark this topic as resolved except Andrea Rennick still has an open issue...

  5. Stas Su?cov
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm, so it's only a settings page issue.

    Issue #91 opened.

    Thanks.

  6. Prometheus Fire
    Member
    Posted 1 year ago #

    Stas,

    I suspect this may also related to multisite. I've got courseware network activated, can through an initial course setup, but thats as far as I can get.

    On the courseware page inside the group, I receive these errors.

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/teatrade/public_html/vbpd.info/wp-content/plugins/buddypress-courseware/roles/roles.class.php on line 269

    Warning: Invalid argument supplied for foreach() in /home/teatrade/public_html/vbpd.info/wp-content/plugins/buddypress-courseware/roles/roles.class.php on line 271

    setup is bp default theme with no other plugins active

  7. Stas Su?cov
    Member
    Plugin Author

    Posted 1 year ago #

    Those are not errors. It states clearly Warning!

    Disable php to report warnings as a temporary workaround.

  8. pawanarora
    Member
    Posted 1 year ago #

    How to disable these warnings...I mean how disable php to report warnings?..and is this warning not to be taken seriously...? because I facing the same error. even on single site wordpress and also on multisite.

    What could be the reason though?

  9. transmediac
    Member
    Posted 1 year ago #

    I'm using courseware on a single site install and receive the same two warnings described above by Prometheus Fire on the courseware group dashboard.

    The warnings disappear once the first member/student joins the group.

  10. Itookmyprozac
    Member
    Posted 1 year ago #

    Hi,

    I have experienced similar problems.

    Using WordPress 3.4.2 & Buddypress 1.6.1 & Buddypress Courseware 0.9.7, in a mu-site environment.

    I have activated Buddypress Courseware on the main site and I can't access to the settings page because of an error related to permissions (I'm superadmin). It's the first time that I get this error. No problems with other plugins.

    Then, I have deactivated BC in the main site and network activated. No BC settings page in any menu. It's supposed to be that way?

    Thank you!

  11. anandbala
    Member
    Posted 1 year ago #

    Hi

    i am working with multisite (sub domain) , in that for theme settings Buddypress settings is not shown i want to enable Buddypress compatible for my sub domains , its working nice for my parent domain .

    Thank u

  12. Stas Su?cov
    Member
    Plugin Author

    Posted 1 year ago #

    This is still WIP.
    Follow this ticket for updates: https://github.com/Courseware/buddypress-courseware/issues/91

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic