WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPig
My site crashed (20 posts)

  1. bandtobuy
    Member
    Posted 1 year ago #

    I made a website http://www.sermonmonster.com/ and I installed buddypig through the wordpress plugin menu. Now I cannot visit the site, and I cannot do anything to edit buddypig because I downloaded it on wordpress, not as a zipped file. Help

    http://wordpress.org/extend/plugins/buddypig/

  2. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like you got it removed because your site is loading now. Did you get anything useful in your server's error logs?

  3. echoman
    Member
    Posted 1 year ago #

    I will say i tried it to see if it would work and received the white page of death. I had to remove it from filezilla and site was back. How much memory does it take to use? I have the "change memory limit" plugin and it's set to 96 mbs. Seems like such a cool idea but sad it's not working.

  4. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Memory usage is going to depend on the size of your site probably, and BuddyPig has only been tested on a site with a few hundred members.

  5. echoman
    Member
    Posted 1 year ago #

    What would you consider the ideal memory usage for this plugin? If i set the memory higher than 96mbs? I disabled all my plugin but buddypress. I believe my webhost allows 256MBS at the most.

  6. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    To be honest I have no idea. You'd have to experiment a bit and find out.

    You can also install the debug toolbar and see how much memory your current install is using: http://wordpress.org/extend/plugins/debug-bar/

  7. Evan Solomon
    Member
    Plugin Author

    Posted 1 year ago #

    I'm curious how many members you guys have in these BuddyPress groups. Thinking about it very briefly and without testing anything, more members might now to produce huge differences in memory usage.

  8. echoman
    Member
    Posted 1 year ago #

    HeY guys sorry for late response just to let you know i haven't opend my sites yet. I'm working on 4 of them. I'll set my memory to about 128 mbs then try again. Pretty much with zero members i receieved the white page of death. I'll keep you posted.

  9. echoman
    Member
    Posted 1 year ago #

    I just set memory all the way up to 256mbs and still white page. So there must be something else interfering. I get the white page of death site wide.

  10. Evan Solomon
    Member
    Plugin Author

    Posted 1 year ago #

    I think this is probably not a memory issue. Can you check your PHP error logs for anything mentioning buddypig?

  11. mareksgregs
    Member
    Posted 1 year ago #

    Same thing just occurred to me. The error is in
    wp-content/plugins/buddypig/pig/activity.php line 7,

    $value = $pig_scores::meta_key;

    I'm not much of a developer though, so I don't know what's missing there or what's too much.

  12. Evan Solomon
    Member
    Plugin Author

    Posted 1 year ago #

    Is there anything else in the error? It's helpful to know the line number, and there's usually also some information about the specific problem that caused the crash.

  13. mareksgregs
    Member
    Posted 1 year ago #

    PHP Parse error: syntax error, unexpected ':'

  14. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    @mareksgregs: What version of PHP are you using?

  15. mareksgregs
    Member
    Posted 1 year ago #

    5.2.17

  16. Evan Solomon
    Member
    Plugin Author

    Posted 1 year ago #

    Buddypig actually requires PHP 5.3 (details below). I updated the readme to reflect that requirement, which I didn't realize existed until now.

    Thanks for helping us find it. Unfortunately, Buddypig won't work on 5.2.17. On the other hand, you should be able to get your version of PHP upgraded to 5.3.something, or even 5.4.something, if you talk to your host.

    * Buddypig references class constants from variables which was added in 5.3.

  17. mareksgregs
    Member
    Posted 1 year ago #

    I don't keep track of PHP version, so thanks for telling me! haha
    Just updated my php to 5.4.8 and it fixed the crashing of the site.
    But the plugin doesn't work either way. I click the pig in the admin bar and it just keeps "Getting piggy..."

  18. Evan Solomon
    Member
    Plugin Author

    Posted 1 year ago #

    Are you sure you sure your web server is using the 5.4.8 version of PHP? You can check with phpinfo().

    Can you also check to make sure the error (not just the symptom) is the same?

  19. mareksgregs
    Member
    Posted 1 year ago #

    I'm sure. I created the phpinfo file for another confirmation.

    There aren't any errors anymore. Just warnings, which are:

    PHP Warning: array_diff(): Argument #1 is not an array in wp-content/plugins/buddypig/pig/questions.php on line 45

    and

    PHP Warning: Invalid argument supplied for foreach() in wp-content/plugins/buddypig/pig/questions.php on line 48

    Oh and by the way, after I updated my PHP, an update for the plugin came up on Dashboard. Could that be somehow involved?

  20. Evan Solomon
    Member
    Plugin Author

    Posted 1 year ago #

    It sounds like you need to tell PIG which group to use: http://wordpress.org/extend/plugins/buddypig/other_notes/

    The plugin update was just me updating the readme to add the PHP 5.3 info.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.