WordPress.org

Ready to get started?Download WordPress

Forums

Broken Link Checker
[resolved] The plugin's database tables are not up to date! (9 posts)

  1. greencode
    Member
    Posted 3 years ago #

    I've just updated this plugin from v0.9.3 to 0.9.5 and I'm now getting an error when I view the broken links. Here's an example:

    Error: The plugin's database tables are not up to date! (Current version : 4, expected : 5)
    [ ] ALTER TABLE <code>wp_blc_filters</code> ADD COLUMN <code>id</code> int(10) unsigned NOT NULL AUTO_INCREMENT
    Database error : Table 'jayne_site.zfw4638_blc_filters' doesn't exist
    [ ] ALTER TABLE <code>wp_blc_filters</code> ADD COLUMN <code>name</code> varchar(100) NOT NULL
    Database error : Table 'jayne_site.zfw4638_blc_filters' doesn't exist
    [ ] ALTER TABLE <code>wp_blc_filters</code> ADD COLUMN <code>params</code> text NOT NULL
    Database error : Table 'jayne_site.zfw4638_blc_filters' doesn't exist

    Please help!

  2. Janis Elsts
    Member
    Plugin Author

    Posted 3 years ago #

    A couple of questions :

    Any idea why the "wp_" prefix in the queries is replaced with "jayne_site.zfw4638_" in the error messages? Is there something in your WP or database configuration that could be changing it?

    Also, if you have direct access to the database, could you please check if the wp_blc_filters table actually exists or not?

  3. greencode
    Member
    Posted 3 years ago #

    The jayne_site is the name of the database and the zfw4638_ is used instead of wp_

    Yes, zfW4638_blc_filters does exist in the DB

  4. Janis Elsts
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry, but I can't make heads or tails of this. Are you using some non-standard method of setting the table prefix for the WordPress DB? Maybe some kind of plugin that rewrites SQL queries on the fly?

    BLC is designed to use the table prefix configured for the site, but apparently that isn't working as expected in this case.

  5. greencode
    Member
    Posted 3 years ago #

    Nope, nothing unusual. All other plugins work perfectly okay and so did this before I upgraded to the latest version?!

  6. Janis Elsts
    Member
    Plugin Author

    Posted 3 years ago #

    Well, you can always reinstall the plugin. That should fix any database issues (but it will lose your current settings, too).

  7. greencode
    Member
    Posted 3 years ago #

    Would that require going into the DB and removing the blc lines and then installing the plugin once again?

  8. Janis Elsts
    Member
    Plugin Author

    Posted 3 years ago #

    Just deactivate the plugin and click its "Delete" link in the "Plugins" tab. This will remove the blc_ tables automatically. Then install the plugin anew.

  9. greencode
    Member
    Posted 3 years ago #

    Thanks. I've deleted the plugin and reinstalled it from scratch. There's now no more errors occurring.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic