WordPress.org

Ready to get started?Download WordPress

Forums

BP Multi Network
[resolved] Activity showing up on both networks? (9 posts)

  1. Peter Martin
    Member
    Posted 2 years ago #

    Having a problem that I'm sure you'll be much quicker to fix than me! My Buddypress installations on separate networks are sharing content...ie, activity on one is reflected on the other.

    I started fresh with a new install and it's still happening, so I'm guessing I've misunderstood a step along the way.

    Steps:

    1. Install latest WordPress.
    2. Enabled Multisite in wpconfig and activated through the dashboard.
    3. Uploaded WP Multi Networks to my plugins folder and activated.
    4. Created an mu-plugins folder in wp-content, uploaded the BP Multi Network plugin to it.
    5. Created two subnetworks.
    6. Added Buddypress to each and activated.

    I'm stumped!

    Test networks are at:
    top level: http://exilesnetwork.com
    subnetwork1: http://sandbox1.exilesnetwork.com
    subnetwork2: http://sandbox2.exilesnetwork.com

    http://wordpress.org/extend/plugins/bp-multi-network/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    If you had BP active on the subnetworks at any point before installing the BP multi netowrk plugin, then the BP networks won't be separated.

    Second thing to check is go to the plugins page in network admin and see if the BP multi-network plugin is in the "Must Use" plugin list.

  3. Peter Martin
    Member
    Posted 2 years ago #

    I see what the problem is. I uploaded the /bp-multi-network folder, when I actually needed the bp-multi-network.php file directly in /mu-plugins to execute. It wasn't showing up in the "Must Use" plugin list.

    Seems to be working on new test networks now - thanks for getting back to me quickly!

  4. Eric Langley
    Member
    Posted 1 year ago #

    I did the same thing. It would be nice if we could flag the directions with a big star, READ this CLOSELY. It's not the normal yada, yada.

    [ Signature moderated. ]

  5. Eric Langley
    Member
    Posted 1 year ago #

    Ron,

    I do not see where this is?
    >Second thing to check is go to the plugins page in network admin and see if the BP multi-network plugin is in the "Must Use" plugin list.<

    Also, if a plugin is in the MU folder why does not need to be activated?
    This from the WP Codex: Must-use plugins do not show in the Plugins page of wp-admin and cannot be disabled except by removing the plugin file from the must-use directory,

    While I have BP Multi Network in MU folder it still shows up in WP Admin...
    [ Signature moderated. ]

  6. Eric Langley
    Member
    Posted 1 year ago #

    Ron,

    I do not see where this is?
    >Second thing to check is go to the plugins page in network admin and see if the BP multi-network plugin is in the "Must Use" plugin list.<

    Also, if a plugin is in the MU folder why does not need to be activated?
    This from the WP Codex: Must-use plugins do not show in the Plugins page of wp-admin and cannot be disabled except by removing the plugin file from the must-use directory,

    While I have BP Multi Network in MU folder it still shows up in WP Admin...
    [ Signature moderated. ]

  7. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    WE resolved this in a thread at http://wpebooks.com.

  8. tgarmon
    Member
    Posted 1 year ago #

    This thread is the most helpful so far. So, Ron, if I setup a network and activated Buddypress at ANY time then BP multi network won't work? Will I need to create a entirely new network and start over? Or can I just de-activate Buddypress and go from there?

  9. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic