WordPress.org

Ready to get started?Download WordPress

Forums

Bookmarks Shortcode
[resolved] List symbols (disc, square, circle) on wrong place (9 posts)

  1. aaanadie
    Member
    Posted 1 year ago #

    If you have a template with more than 1 column, then you can see list symbols (disc, square or circle) showing in a wrong position:
    Suppose your template have 2 columns and shortcode is at right, then disc symbol appears in the left colum.

    This issue is happening for Firefox and IE, in Chrome all is OK.

    http://wordpress.org/extend/plugins/bookmarks-shortcode/

  2. Shea Bunge
    Member
    Plugin Author

    Posted 1 year ago #

    This would be a problem with the wp_list_bookmarks() function (part of the WordPress core), not a problem with Bookmarks Shortcode.

  3. aaanadie
    Member
    Posted 1 year ago #

    You are right, but you could avoid that issue changing that symbol inside of Bookmarks Shortcode.
    Link View plugin works OK but does not have exclude_category, and I need it.
    Your plugin is almost perfect, thanks.

  4. Shea Bunge
    Member
    Plugin Author

    Posted 1 year ago #

    I can't make any promises, but I'll have a look at how Link View does it and try and implement that functionality into the next major version of Bookmarks Shortcode.

  5. aaanadie
    Member
    Posted 1 year ago #

    Thanks a lot

  6. Shea Bunge
    Member
    Plugin Author

    Posted 1 year ago #

    Hello aaanadie,
    I'm actually not quite sure what you mean. Could you please give me a link to the page (or a screenshot of the page) where the shortcode is used? Thanks.

  7. aaanadie
    Member
    Posted 1 year ago #

    Hello,
    this is a testing link:

    http://1energy1.com/wp/testpage1/

    if you open it on Firefox then you will see list symbols on the wrong column.

  8. Shea Bunge
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    Thanks for the link. I've had a look at the source-code and I have come up with two ways to resolve your problem:

    If you want to keep the dots next to the category headings, simply wrap the shortcode in <ul> and </ul> tags. (You will need to use the HTML editor, not the visual editor.)
    Example: <ul>[bookmarks exclude_category=42]</ul>

    The other option is adding the 'category_before' and 'category_after' arguments to the shortcode and changing the lt;li> and lt;/li> tags that surround the category into div tags or something similar.

    Example: [bookmarks exclude_category=42 category_before='<div id=%id class=%class>', category_after='</div>']

  9. aaanadie
    Member
    Posted 1 year ago #

      worked perfect:
      http://1energy1.com/wp/testpage1/
      Thanks

    Topic Closed

    This topic has been closed to new replies.

    About this Plugin

    About this Topic