WordPress.org

Ready to get started?Download WordPress

Forums

Bol.com Partner Program Plugin
[resolved] Fatal error on activation (11 posts)

  1. Mirjam78
    Member
    Posted 1 year ago #

    Hello,

    I looked on this support forum and saw a lot of people with the same fatal error I get when I install this plugin. I have installed your version 1.0.4 but I get the fatal error anyway. Did I not download the right version? Also tried to install from the adminpanel but with the same fatal error as a result.

    Could you please help me? Because I really want to use this plugin.

    http://wordpress.org/extend/plugins/bolcom-partnerprogramma-wordpress-plugin/

  2. Mirjam78
    Member
    Posted 1 year ago #

    Text says

    Parse error: syntax error, unexpected T_FUNCTION in /home/******/domains/****************.nl/public_html/wp-content/plugins/bolcom-partnerprogramma-wordpress-plugin/bolcom-partnerprogramma-wordpress-plugin.php on line 14

  3. Netvlies
    Member
    Plugin Author

    Posted 1 year ago #

    bolcom-partnerprogramma-wordpress-plugin.php on line 14 involves the use of namespaces in the code and PHP5.3 or higher is required. Please contact your hosting provider.

  4. jrf
    Member
    Posted 1 year ago #

    The current WP version requires PHP 5.2. Requiring PHP 5.3 for your plugin is a bit over the top unless you cannot archieve the same functionality with PHP5.2, which I seriously doubt.

    Contacting your hosting provider will for most WP users be useless as the change from 5.2. to 5.3 for a lot of applications is quite a biggie and shared hosts therefore will mostly offer 5.2.

    Please update the plugin readme information to warn people that installing this plugin will be useless unless you are hosted on PHP 5.3. That way you can spare people the frustration of wasting time on a plugin which will not work in theire setup.
    I would also advise the bol.com website which refers to your plugin to update with the same warning.

  5. lucasdegen
    Member
    Posted 1 year ago #

    I deleted the plugin after having the same fatel error on line 14. Now I'll just add the link to bol.com in my custom post type I made.

  6. Nikki@365Gaming
    Member
    Posted 1 year ago #

    I have the same problem trying to activate the plugin, my hosting however supports 5.2, 5.3 and even 5.4....so why am I getting the same fatal error?

  7. jrf
    Member
    Posted 1 year ago #

    @Nikki

    Have you checked on which PHP version you are running WP ? That your host supports several versions, does not automatically mean you are on PHP5.3+

    Try phpinfo()

  8. cbahida@gmail.com
    Member
    Posted 1 year ago #

    I will do the same. Bay Bay bol.com

  9. Nikki@365Gaming
    Member
    Posted 1 year ago #

    I checked it and make sure the version is 5.3

    The plugin is installed but the widget give fatal errors anyway :(

  10. CyberRein
    Member
    Posted 1 year ago #

    I am using WAMPserver implementation using Apache 2.2.22; PHP 5.4.3; MySQL 5.5.24.
    When I activate the plugin I get this error message:
    (!) Fatal error: Call to undefined function Buzz\Client\curl_init() in c:\wamp\www\wp-content\plugins\bolcom-partnerprogramma-wordpress-plugin\vendor\kriswallsmith\buzz\lib\Buzz\Client\Curl.php on line 13

    I did activate the curl.php extention, but it still doesn't work.

    Does anybody have the same issues?

    Thanks.

  11. jrf
    Member
    Posted 1 year ago #

    @CyberRein,

    You have a different issue from the issue discussed in this thread. Please open a new thread.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags