WordPress.org

Ready to get started?Download WordPress

Forums

Bogo
[resolved] Error 404 on pages (13 posts)

  1. ifaist0s
    Member
    Posted 1 year ago #

    My site is in Greek, so all of the articles and pages are in Greek. The URLs are also in Greek (for SEO reasons). The site, pages, articles were already set up when I installed Bogo (development version > http://wordpress.org/support/topic/blank-dashboard-after-bogo-20-activation?replies=3). The only reason I installed Bogo was for me to be able to browse the Admin Dashboard in English, which works well.

    Today I decided to edit a page but after I did so, I kept getting error 404 when trying to see the page. Needless to say that I didn't change it's URL, when editing the page, just the content.

    After some troubleshooting, I decided to deactivate Bogo. When I updated the page again, after the deactivation of Bogo, the 404 error went away. A simple refresh on the same URL that was giving me the 404, fetched the page.

    I don't know if this is a bug or a feature, but what I'd like to ask is: Do I need to have a version of the page for every language, in order to avoid 404 errors? Or am I missing something else?

    Thanks!

    http://wordpress.org/extend/plugins/bogo/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Do I need to have a version of the page for every language,

    No, you only need pages for necessary languages.

    I'm not sure whether there are troubles happening or working normally without checking the actual site. Can you share the URL? And what is the current WPLANG setting in your wp-config.php?

  3. ifaist0s
    Member
    Posted 1 year ago #

    Sure, here is the link
    http://BitcoinX.gr

    ... and the setting
    define('WPLANG', 'el');

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    OK, which page was 404?

  5. ifaist0s
    Member
    Posted 1 year ago #

    Mornings!

    Oh you wanted the link for the specific page... Here it is
    http://bitcoinx.gr/%CE%B1%CE%BD%CF%84%CE%B1%CE%BB%CE%BB%CE%B1%CE%BA%CF%84%CE%AE%CF%81%CE%B9%CE%B1/

  6. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    I tested on my local environment to create a page with name "ανταλλακτήρια" but I had no problem.

    It might be relating to permalink setting. What is your permalink setting?

  7. ifaist0s
    Member
    Posted 1 year ago #

    Apologies for the late reply...
    The name of the page, doesn't seem to cause the problem, because it existed before Bogo and was working fine, and still is when I deactivate the plugin and edit the page.

    Does Bogo check the browser for accepted languages or the language preference of the logged in user, and tries to locate the X language version of the page? And if it doesn't find it, throws the 404 error?
    I say that because the following happens:
    1) Bogo deactivated - Page loads OK
    2) Bogo activated - (F5 - refresh) page loads OK
    3) Update page - (F5 - refresh) > 404
    4) Deactivate Bogo - (F5 - refresh) > 404
    5) Update page - (F5 - refresh) page loads OK

    When updating the page, I only go to the page in wp-admin and hit the update button, changing nothing else.

    BTW, my permalink setting is: http://WebSite/sample-post/

  8. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Does Bogo check the browser for accepted languages or the language preference of the logged in user, and tries to locate the X language version of the page? And if it doesn't find it, throws the 404 error?

    No, currently it doesn't chech the request header of language preference.

    3) Update page - (F5 - refresh) > 404

    At this time what is your user language setting shown in the admin bar? And after updating the page, what permalink URL is shown below the title field?

  9. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    BTW, my permalink setting is: http://WebSite/sample-post/

    What option have you chosen in the Permalink Settings (Settings > Permalinks) page?

  10. ifaist0s
    Member
    Posted 1 year ago #

    Thank you for taking the time to reply and look into it :)

    Quick replies:
    Permalink setting
    Settings > Permalinks > Under common settings:
    Post name http://BitcoinX.gr/sample-post/

    User language setting: English (but the same 404 happens even if I choose Greek)
    The URL never changes... It's always the same http://bitcoinx.gr/%CE%B1%CE%BD%CF%84%CE%B1%CE%BB%CE%BB%CE%B1%CE%BA%CF%84%CE%AE%CF%81%CE%B9%CE%B1/
    either when I get the 404 message (step 3 and 4) or when the page is OK (step 5).

    The workaround for now is to update the pages when Bogo is deactivated. If I enable Bogo after the page-update, everything is fine :)

  11. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for the detailed information. I believe I could identify the cause of the issue and fix it.

    Could you download and try the "Development Version" from here?
    http://wordpress.org/extend/plugins/bogo/developers/
    (find "Other Versions" - "Development Version")

    I hope it will work.

  12. mikomani
    Member
    Posted 1 year ago #

    Hi,

    I have exactly the same problem....
    I am using your excellent plugin! in an Arabic (RTL) site. The entire front-end is in Arabic (nothing in English) and the editor is also using the front-end in Arabic.

    I actually installed WP 3.5.1 in Arabic (native WP version).

    But I need my back-end in English so I installed your plugin and it is amazing!!!! If I could delete/remove the all English version and files except of those required by Bogo to translate the back-end to English, I would have done it.

    BUT, I suspect that Bogo also creates a taxonomy problem that "bothers" Google's robots.
    Google now shows that all my tags and categories are duplicated:
    native version is: my-site.com/tag1
    Useless/unwanted ver is: my-site.com/en/tag1

    If I try to create a new post or page, using my Bogo's English back-end, it will automatically create it with the my-site.com/en/abcdefg metalink. But I do not need or want these /en/ to show up on my website.

    Any solution?

  13. webbrewers
    Member
    Posted 1 year ago #

    Same problem here:
    http://yorubacorp.com/yoruba/es/home/
    Should we just try the developer version?
    I double checked and this only seems to be a problem with the home page, I guess because it conflicts with the way the home page url is rewritten as domain.com/
    So it's no big deal!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic