WordPress.org

Ready to get started?Download WordPress

Forums

Big MailChimp
[Plugin: BigMailChimp] Error message on install (15 posts)

  1. sdbrougher
    Member
    Posted 2 years ago #

    I downloaded and then uploaded bigmailchimp and then I go the following error message.
    Fatal error: Class 'MCFormWidget' not found in /home/content/67/9148767/html/wp-includes/widgets.php on line 324

    I cannot get out of this screen and back into wordpress. Help, what do I do?

    http://wordpress.org/extend/plugins/bigmailchimp/

  2. subjectified
    Member
    Posted 2 years ago #

    Please, please help! I just did the same thing. Put the install directory where it's supposed to go, activated plugin from my dashboard, and now my whole site is down with the same error and I cannot access my admin panel at all.

    This is totally paralyzing to my business until it's back up. Please let me know what to do ASAP. Thank you.

    Update: I deleted the plugin from the directory and the site came back up, but with some of the functionality messed up. I'm not sure how to fix it. Please be in touch with me to figure out how to uninstall properly.

  3. sdbrougher
    Member
    Posted 2 years ago #

    i agree. It is so paralyzing to what I have to do as well.

    It is even more frustrating that the only way to get help is through these forums and have to wait and see if anyone responds. It really makes me mad and frustrated.

    Somebody out there, please help!!

  4. ahest
    Member
    Posted 2 years ago #

    I had the same problem. Solved it by following the instructions here to disable the plugin

  5. subjectified
    Member
    Posted 2 years ago #

    Thanks for posting that link. That's essentially step-by-step instructions of what I described in my last comment.

    Problem is, there are parts of my website functionality that are now not working after adding and deleting this plug-in. This procedure doesn't address any damage that's been done to the structure of the site.

  6. ahest
    Member
    Posted 2 years ago #

    I have not noticed any problems with my site after deleting the plugin. I guess I was lucky.

  7. Big Employee
    Member
    Plugin Author

    Posted 2 years ago #

    In order for a widget to work your sites must supports Widgets and Widget Areas (sidebars, footer, ...). You can read all about that on WordPress http://codex.wordpress.org/Widgets_API. Also make sure your site (specially the theme you are using) is running error free.

    Stating which WP and PHP version and list of installed themes and plugins are useful to us when troubleshooting.

  8. sdbrougher
    Member
    Posted 2 years ago #

    My site does support Widgets because I have installed quite a few.

    The problem is once I uploaded and activated all that shows up now is the error message and I cannot get to any other area of wordpress. I am essentially locked out.

  9. sdbrougher
    Member
    Posted 2 years ago #

    You can see what I am talking about by visiting my site:

    http://aspoonfulofgoodliving.com/

  10. ahest
    Member
    Posted 2 years ago #

    I had the same exact error message until I removed the plugin.
    PHP Version: 5.2.17
    Wordpress version: 3.3.2
    Theme: Cloriato Lite
    widgets are supported and I am using the CafePress and Image (Jetpack) widgets now
    Plug-ins:
    Awesome Flickr Gallery
    CafePress Widget
    Embed PDF
    Event Registration
    Google Analytics for WordPress
    Jetpack
    Mailchimp
    W3 Total Cache

  11. sdbrougher
    Member
    Posted 2 years ago #

    Ok, here is my deal. How do I remove the widget if I cannot get into my account??????

  12. ahest
    Member
    Posted 2 years ago #

    follow the link I posted above and it tells you exactly what to do

  13. sdbrougher
    Member
    Posted 2 years ago #

    @ ahest, thank you. I somehow missed your previous entry with the link.

    After several tries, I finally was able to remove it.

    Thank you,
    Sandra

  14. cre8tvnrg
    Member
    Posted 2 years ago #

    @ sdbrougher - I had the same issue today too, I got a fatal error and it locked me out of my site. I am on Hostgator, so I just went to my cpanel, then to my plugin files and deleted the plugin. And my site was back. Hopefully you have hosting with a cpanel.

    @Bigemployee - I do have a site with widgets enabled and have this same issue. My site is running error free and I am using WP 3.3.2 and the most recent PHP ( 5 I believe) I can install the BigMailChimp Plugin but when I activate it, I get a Fatal Error. and it locks me out of my entire site. I am using ithemes Builder. And have never had a fatal error until trying to activate your plugin. Any advice would be helpful - or I need to try another MC plugin. :) Thanks!

  15. joshberna
    Member
    Posted 1 year ago #

    Yes make sure you go back in and delete the widget....

    then go back to the wordpress directory and make sure you rate it...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.