WordPress.org

Ready to get started?Download WordPress

Forums

BigContact Contact Page
[resolved] [Plugin: BigContact] Google maps address not holding (6 posts)

  1. davidpey
    Member
    Posted 2 years ago #

    Hi Arian/BigContact team,

    Just another bug that has come up:

    First issue: My office location is "Hyde Park Shopping Centre, Johannesburg, South Africa." It is listed on Google Maps, South Africa (https://maps.google.co.za/). But if I change the map location in the BigContact settings page, "Hyde Park Shopping Centre, Johannesburg, South Africa" doesn't show up (blank Google Maps page).

    But if I change the location to the actual physical address of the Centre ("Cnr Jan Smuts Ave and William Nicol Drive, Johannesburg"), then the appearance of the map on my contact page is accurate.

    Second issue: If I go back in to the Form Options page and make any other changes, the physical address location that I had previously input changes to a more generic address (William Nicol Drive). If I want the correct marker to return, I have to go in and change the maps address at the end of every session of edits.

    Question: Are the issues listed above a Google Maps issue, or a BigContact issue?

    Thanks gents!

    David

    http://wordpress.org/extend/plugins/bigcontact/

  2. davidpey
    Member
    Posted 2 years ago #

    Just an incidental pointer as well:

    On the widgets page, the description under BigContact is: Display your cantact information

  3. arianKhosravi
    Member
    Plugin Author

    Posted 2 years ago #

    Hi David,

    When you enter an address the plugin verifies it with Google Maps Api and gets the formatted address as Google APIs provides. We did not want to clutter the small map area with popup bobbles to display directions link and extra information. Hence, the link bellow the map takes the user to the Google Maps page where the destination (your business) is already loaded in the "B" field. For that reason we want to ensure the address is accurate on Google Maps. It is possible that the results Google Maps API returns is different from maps.google.com.

    For your second issue the formatted address tries to find the best street address based on your input. So instead of cross streets try the street address of the location.

    Do you still have to refresh the page to see the changes take effect?

    Thanks for your great suggestions and feedback.

    Best,
    Arian

  4. davidpey
    Member
    Posted 2 years ago #

    Hi Arian,

    Many thanks for the careful explanation.

    Yes, I suspect that .com Google Maps may return different results to .co.za

    I am unable to give an actual street location, since my business is located within the shopping centre - which is located at the crossing of the two roads (there is no street address strangely).

    As an aside: yes, I do always have to refresh the Form Options page to see changes take effect (as per this post). This is, albeit, separate from the Google Maps issue. Whenever I refresh, it loses the crossroads address. But there is a way around it.

    Thanks again!

    David

  5. arianKhosravi
    Member
    Plugin Author

    Posted 2 years ago #

    Dave,

    If we use the inserted address instead of that Google APIs return then in case there are no results found the map will show an empty canvas. Meanwhile, if you do not absolutely need to show the map you can remove your API Key and enter any address you desire. The address will appear as a directions link like before. This is hardly a solution and let's hope Google will provide better support for SA in near future.

  6. aaronb
    Member
    Posted 1 year ago #

    I am having trouble with the appointment calendar and the google maps displaying on my webpage even though the shortcode has everything turned on [bigContact form=on appointment=on phones=on emails=on hours=on map=on]...Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic