WordPress.org

Ready to get started?Download WordPress

Forums

Better YouTube Embeds
[resolved] YouTube link remains an ordinary link (16 posts)

  1. DaniellaGiovanna
    Member
    Posted 2 years ago #

    Hey guys,

    I'd love to use your plugin but it doesn't seem to be working for me. Any link I put in remains an ordinary link.

    I'm working on a rather fresh install of WordPress and deactivated the 3 other plugins I was using to see if any of them would be colliding with yours. That didn't seem to do anything.

    I've double check and yes, the pluging IS activated (hehe).

    I'm kind of lost here and I hope you will be able to provide me with a solution (as soon as we find the cause of the problem, that is).

    Thanks,

    Daniella

    http://wordpress.org/extend/plugins/dirtysuds-embed-youtube-iframe/

  2. Pat Hawks
    Member
    Plugin Author

    Posted 2 years ago #

    In the admin interface, make sure you have the following option enabled (a little check in the box).

    Settings -> Media -> "When possible, embed the media content from a URL directly onto the page. For example: links to Flickr and YouTube."

  3. DaniellaGiovanna
    Member
    Posted 2 years ago #

    Thank you for your swift reply.

    But, I already have that enabled. Sorry, forgot to mention that in the previous post. Oh, and the link is on a line of its own, too. It should just be an ordinary YouTube link, right? Like, copied from the address bar? There's nothing fancy behind the link either ("&something").

  4. Pat Hawks
    Member
    Plugin Author

    Posted 2 years ago #

    Ok...
    You're posting the URL on it's own line, with no formatting or anything, right?

    Can you post the exact URL? It sounds like WordPress is having an issue detecting that it is a YouTube URL.

  5. DaniellaGiovanna
    Member
    Posted 2 years ago #

    I found the causeS:

    1. I was using the WYSIWYG editor in the WordPress back end and what that did was, it was putting a link around the YouTube URL ("a href=..."). When I removed the link it was fine.

    2. It also seems to fail when using the Front End Editor (http://wordpress.org/extend/plugins/front-end-editor/) since this editor puts a <p> around.

    I'm basically searching for ways to make website maintenance easier on my clients - the Front End Editor and your YouTube plugin could help me with that. These are not bugs so of course you could just leave these things, and I understand if it's not possible to "fix" these things at all, but nevertheless it'd still be awesome if at least the <p> thing would work.

    I'd like to hear if you have any thoughts on this. Thanks again!

  6. irwired
    Member
    Posted 2 years ago #

    Thanks for the great tip.

    Yes indeed if there is anything other than the code that appears in the address bar when your selected video is displayed in YouTube it will not work.

    I have found it easier to add the code to the HTML editor.
    Then save and check to see if any code has been added after you hit the save button. It should look like this:

    http://www.youtube.com/watch?v=yourvideo

  7. Pat Hawks
    Member
    Plugin Author

    Posted 2 years ago #

    One more tip (well, kind of a hack, but it works in a pinch)
    You can always surround the URL with the [embed] shortcode. This also allows you to change the default height and width.

    [embed height='300' width='400']http://www.youtube.com/watch?v=y-LsEajbD4I[/embed]

  8. fembiz
    Member
    Posted 2 years ago #

    Hi guys, I tried this plugin as well and it doesn't work. Has anyone been able to figure out what the problem is?

  9. Pat Hawks
    Member
    Plugin Author

    Posted 2 years ago #

    fembiz You'll have to be a bit more specific than that.
    What doesn't work?

  10. fembiz
    Member
    Posted 2 years ago #

    The youtube link remains an ordinary URL. It doesn't substitute it with the embed code as described.

  11. Pat Hawks
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, so you're not having a problem with the plugin, you're having a problem with your WordPress settings.

    http://wordpress.org/support/topic/plugin-better-youtube-embeds-youtube-link-remains-an-ordinary-link?replies=10#post-2150504

  12. fembiz
    Member
    Posted 2 years ago #

    No. The problem is not with the WordPress settings. My settings are fine. The problem is with the plugin.

  13. Pat Hawks
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry, perhaps I didn't explain very well.

    The plugin is not responsible for turning the YouTube link into the embeded video. That's a WordPress feature.

    What the plugin does it change the returned YouTube Flash embed code into a mobile friendly embed code. If you're not even seeing a Flash embed, then of course the plugin hasn't yet had a chance to do it's job.

    Let me reiterate, the plugin code will never even be called if WordPress does not try to return a Flash YouTube embed.

    This topic has been marked as Resolved, as the two original posters have been able to fix their problems. If you are having a problem with WordPress's oembed system, I would suggest reading the manual for more information on how that system works.

  14. fembiz
    Member
    Posted 2 years ago #

    I found an alternative way to this anyways. But thanks for the info

  15. goviral
    Member
    Posted 1 year ago #

    I have got the plugin working and the link is displaying the video in my desktop browser window but I can't get the video in my HTC Legend 2.2 Android phone.

    I understood that this plugin would make videos play in mobile browsers including in Android.

    Any ideas what I might have done wrong?

    Thanks

  16. Pat Hawks
    Member
    Plugin Author

    Posted 1 year ago #

    I do not own the phone in question, so I have no way to debug.
    For what it's worth, I can't recreate this problem on any of the phones I do own.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic