WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[Plugin: Better WP Security] Registration doesn't work if Hide Backend option is on (v3.4.4) (11 posts)

  1. David Choi
    Member
    Posted 1 year ago #

    When Hide Backend is turned on, the registration will not work, it won't display any message or send out email to the user. Although the login works fine.

    I am using the latest version 3.4.4.

    Any suggestions? Thank you.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. codzign
    Member
    Posted 1 year ago #

    im also have this bug, any ideas??

  3. littleb1977
    Member
    Posted 1 year ago #

    I appear to have the same

  4. MacItaly
    Member
    Posted 1 year ago #

    Me too, exactly the same.
    WP 3.4.2 and BWS 3.4.4
    Any ideas?

  5. xmasons
    Member
    Posted 1 year ago #

    Same issue, same fix.

    WP 3.4.2 and BWS 3.4.4

  6. Gr1dsl
    Member
    Posted 1 year ago #

    Same issue here also.
    Any idea is welcome!

  7. Ulme
    Member
    Posted 1 year ago #

    The Problem ist that the action attribute of the registration form is not modified by the plugin.
    To solve this open wp-login.php, go to line 547 and change
    wp-login.php?action=register

    to

    wp-login.php?xxx&action=register

    xxx has to be the secret key from BWPS

  8. nickzee
    Member
    Posted 1 year ago #

    Thanks @ulme! This worked for me. Just have to remember to change it each time WP updates.

    @bit51 Thank you for this great plugin! Do you approve of this method or is there a better way?

    Thank you again. (not sure if @ works here...)

  9. Anupam Saha
    Member
    Posted 1 year ago #

    I didn't like to way to fix the registration issue by hacking the core wp-login.php. So, I've came up with the fix that's working in one my client's site. Please read about the fix here - http://wp.me/pP6af-4n

  10. Chris Homko, MS ATP
    Member
    Posted 11 months ago #

    This fix does not work anymore with WordPress 3.6 and Better WP Security 3.5.6 build 3063. Line 347 in file "wp-login.php" no longer corresponds to "wp-login.php?action=register". Furthermore, this seem to be broken regardless of whether "Enable Hide Backend" is enabled or not. I have it disabled and still get Better WP Security rewriting my register slug to include the "Hide Backend Key" appended to the URL as follows when not logged in as an Admin:

    wp-login.php?action=register?g5nlucjlvb4tp0kqkjtg

    This will return a "404 Page Not Found" error.

    FYI, editing the "functions.php" in the theme directory does not work either for. The website does not even load at all. I am using theme Custom Community PRO by Themekraft.

  11. Chris Homko, MS ATP
    Member
    Posted 11 months ago #

    I figured out my problem. This is NOT a Better WP Security issue. I created a bad link that has the ?g5nlucjlvb4tp0kqkjtg5 added to the URL.

    Although it is true that the fix will no longer work because you should not need it. Please disregard my posts.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic