WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] [Plugin: Better WP Security] READ THIS before creating a new thread. (34 posts)

  1. Hello!

    First of all, if you need support for Better WP Security you're in the right place. That said, before posting a new thread please try the following to see if it resolves your issue:

    1. Try the development version. There's a good chance that if you have in fact encoutered a bug others have too and I might have already pushed a fix.
    2. Search the forums to see if someone has already posted with the same issue you're having. Chances are you can solve your problem without typing a single word
    3. Please make sure the problem you're experiencing is indeed caused by Better WP Security by disabling other plugins and enabling the default Twenty-eleven theme.
    4. Finally, if you're locked out of your site due to a server error open your .htaccess and remove the Better WP Security section from it. As much as I try to make this plugin perfect on all sites the fact is it is an impossible tasks. Certain server configurations can indeed cause issues. Fortunately, once we get you back in your site we can then determine which feature is conflicting and solve it.

    Please keep in mind that nearly every issue folks have with Better WP Security is due to either a server settings conflict or a plugin/theme conflict. That said, once we can isolate the issue we should be able to come up with an adequate solution.

    Thank you,
    Chris Wiegman

  2. Explodos
    Member
    Posted 2 years ago #

    Please help me I installed your plugin and now my websites are 500 internal server error.

    I contacted my hosting provider and they renamed my htaccess file.

    All my links are 404d

    Please help me regain my website.

    I have no clue what to do.

  3. Blake Pounds
    Member
    Posted 2 years ago #

    I would like to know what are the "user agents" when you want to ban an entity? Is the "user agents" the members on the website?

  4. dogweather
    Member
    Posted 1 year ago #

    If only searching the WP Better Security support forum was reasonably easy. It's not.

  5. dtmp
    Member
    Posted 1 year ago #

    I'll agree dogweather, how do you only search support posts for a single plugin instead of the entire wordpress.org site!!!! I guess I'll just post another topic....

  6. Arevico
    Member
    Posted 1 year ago #

    Submit your issues with the worpdpress.org website to the kvetch also, that way the staff will see it.

  7. Sunidaze
    Member
    Posted 1 year ago #

    Finally, if you're locked out of your site due to a server error open your .htaccess and remove the Better WP Security section from it.

    How do you do this if the file permission of the .htaccess file is set to 0444 and you're locked out of the site and can't access the server tweaks to change it back?

  8. agljklcnvtx
    Member
    Posted 1 year ago #

    How do you do this if the file permission of the .htaccess file is set to 0444 and you're locked out of the site and can't access the server tweaks to change it back?

    If you are locked out from WP, access your site Via Cpanel (your ISP provider should have provided you credentials) change the permissions there and edit the file there.

  9. webtonic
    Member
    Posted 1 year ago #

    Hi
    I am getting a message after running detect>check for files and changes
    "Better WP Security has noticed a change to some files in your WordPress installation. Please review the logs to make sure your system has not been compromised."

    When I view the logs at

    Logs >Changed Files I see "no items found"

    Thoughts?

  10. dotcomdotbd
    Member
    Posted 1 year ago #

    Hello,
    Its conflicting with google font. Please help...

    Thanks

  11. mmeadpond
    Member
    Posted 1 year ago #

    Hello, I've just installed it to a client site and got the following warning immediately:

    Notice: Undefined variable: iwp_action in /data/26/2/7/139/2496302/user/2733991/htdocs/wp-content/plugins/better-wp-security/inc/secure.php on line 22

    I disabled the plugin but wondered what I'm doing wrong.

    The site is: http://pacificfreedomfoundation.org

    WordPress 3.5.1
    Builder iThemes platform
    Using Backup Buddy

    Thank you.

  12. Craig Hesser
    Member
    Posted 1 year ago #

    Hello,
    I just upgraded the plugin to 3.4.8 and I cannot address any posts from the home page.
    Situation:
    - HostGator Apache hosting
    - Win 7 (does the same thing with XP on different machine)
    - Firefox 18 latest and IE 9 latest have same results
    - http://trakehnertube.com/
    - WP 3.5.1
    - Theme: Covert Video Press 1.4 (but does the same thing with WP 2012)
    - Plugins on or off makes no difference.
    - Also tried the plugin development version from about 20 minutes ago (midnight GMT)
    - Isolated the problem to the Ban Users box "Enable Default Banned List" - check the box and confirm - problem, uncheck the box and confirm - no problem.
    - The error message is "Not found on this server. Plus a 404 error trying to use an Error Document to handle the request."

    Hope you can fix it!

    Jimmy Craig

    P.S. The box is unchecked now so my viewers can see the site!

  13. Craig Hesser
    Member
    Posted 1 year ago #

    P.P.S. There were no problems with this function with the previous plugin version 3.4.7, and my 7 other sites are still using this without problems.

  14. Craig Hesser
    Member
    Posted 1 year ago #

    Well, I went back to the other sites, and upgraded them to 3.4.8 to see what is happening, and discovered that all except for the one can use version 3.4.8 with no problems. I must have a conflict of some sort with the one site. More research is required... :-)

  15. ali1370
    Member
    Posted 1 year ago #

    I installed wp better security and after this install gave "SSL connection error".

    Can you help me to solve it??

  16. Craig Hesser
    Member
    Posted 1 year ago #

    Hi Ali1370

    I am no expert, but try this:

    First, I assume you do not have an SSL Security Certificate for your hosting on your site. If you do have the SSL installed, then I have no experience here.

    If you do NOT have SSL installed, do the next steps.

    If you DO NOT KNOW if SSL is installed or not, assume that it is not and do the next steps.

    - Go to the Security Settings and select the section called "SSL"

    - Make sure the first box "Enforce Front End SSL" is set at "Off". If it is not at off, change the setting to "Off"

    - Just to be sure, uncheck the other two boxes ("Enforce Login SSL" and "Enforce Admin SSL")

    - Save by clicking the "Save Changes" button at the bottom.

    - Item 21 on the Dashboard should be in blue font.

    That is all we can do here, if you still get the message, then that is above my level of competence! ;-)

  17. Craig Hesser
    Member
    Posted 1 year ago #

    Further to my problem with one site above...

    I believe I found my problem:

    I used names for the replacements that included capital letters and symbols (generated these as passwords online). Upon reflection and further investigation, I (finally) discovered that, since these are used in html/php addresses, they should not have capitals and special characters, only lowercase and numbers. I redid the same thing, and used the same replacements, just eliminating the special characters and converting the caps to lower case, and everything works!

    Something learned.

  18. albert_690
    Member
    Posted 1 year ago #

    I can no make the hide backend function to work, when i type wp-login.php goes to not found that's ok, but when I type the custom URL, "administrator" for example also goes to not found page, so no way to enter to the backend at all, any help?

    LINUX, APACHE, WP V.3.5.1

  19. chp2009
    Member
    Posted 1 year ago #

    I went in to the database and didn't see a bwps table for the 404's. I emptied the other tables and still didn't get access. I don't see the .htaccess file.

  20. waynepickard
    Member
    Posted 1 year ago #

    This is trivial, but there is a typo in the Site Lockout Notification emails.

  21. evilmc
    Member
    Posted 1 year ago #

    How to disable thit plugin??? My wp-admin show blank page and I don't have access login????

    I use WP 3.5.1 and now I can't update my website. Please, help me!

  22. Craig Hesser
    Member
    Posted 1 year ago #

    @evilmc
    Go into the files with your ftp device and either rename or delete the plugin. Then restart with the wp-admin (if that works). I'm not sure what to do if wp-admin still does not work, but I think the next step is to take the entries from BWPS out of the .htaccess file.

    Good luck

  23. Craig Hesser
    Member
    Posted 1 year ago #

    @chp2009

    Sorry, this is probably after you have solved the problem, but the .htaccess file should be located in the same directory where your wp-admin, wp-content, and wp-includes folders are. If you installed WP in a subdirectory, there will be two .htaccess files, one in the WP root, and one in the account root (where you put the favicon, the google, bing, etc. identification html files, etc.).

    Don't forget to be sure that your editor can see a file where the name starts with a "." as in ".htaccess"

  24. fireflyuniverse
    Member
    Posted 1 year ago #

    I recently installed this plugin because my WordPress blog had been hacked. The plugin has been great in making me feel better about what is going on!

    However, I have created a list of banned users based on my error logs because certain user's IP addresses are coming from Russia, France, Japan, etc. I just noticed, though, that some of the IP addresses that I have banned are still attempting to access old files and getting 404 errors. Is the ban working to not allow them to access my site even though I am still seeing them in the error logs?

    Thanks!!

  25. BlogKing2
    Member
    Posted 1 year ago #

    Latest release kills media posting. Looks fine but nothing gets inserted in page or post.
    Disables plugin and now can't see any media files.

    I am really NOT happy with the state of wordpress plugins. WE are not you test bed. You should do adequate testing before release especially a plugin of you nature. I have work to do, not spend time on your plugin bugs.

    And don't blame other plugin or themes.
    These is really getting out of hand. You developers should enforce std on other developers. Not throw it out to the user base to handle.

  26. BlogKing2
    Member
    Posted 1 year ago #

    Latest release kills media posting. Looks fine but nothing gets inserted in page or post.
    Disables plugin and now can't see any media files.

    I am really NOT happy with the state of wordpress plugins. WE are not you test bed. You should do adequate testing before release especially a plugin of you nature. I have work to do, not spend time on your plugin bugs.

    And don't blame other plugin or themes.
    These is really getting out of hand. You developers should enforce std on other developers. Not throw it out to the user base to handle.

  27. Pouya Azizi
    Member
    Posted 1 year ago #

    hi dears , i turned ssl option and my site is unavilable, haow i can redo this action ? is there anyone to help me ?

  28. scarlettr8
    Member
    Posted 1 year ago #

    URGENT!!! I got the dreaded email notice about being locked out because of too many login attempts and now I am completely locked out of the Admin section. I am not on the IP address indicated in the email and database lockout table. I've deleted BWPS entries from the .htaccess file, deleted BWPS from the plugins folder, deleted the BWPS tables from the database. I've removed all plugins to check for incompatibility, then finally manually re-installed WordPress and my basic theme from fresh versions...all methodically. Still get the blank wp-admin page. I get the wp-login.php page but that goes to a blank wp-admin. This happened two days ago, so the expiry date/time on the lockout wasn't even working.

  29. jpw94
    Member
    Posted 1 year ago #

    Is there a way to search ONLY the BWPS forum?

  30. mans123
    Member
    Posted 1 year ago #

    Hi,

    I use article builder to do autoblogging, after installing better wp security plugin, article builder was not able to login to my blog. I am getting the error message " invalid user/password".

    i have updated the new username and password on article builder, now i have even uninstalled this plugin and restored my blog from my backup but still i keep getting this error message.

    any ideas what can be the possible problem? and how to resolve it?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.