WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] [Plugin: Better WP Security] Google Maps API (12 posts)

  1. shazahm1
    Member
    Posted 2 years ago #

    The plugin strips the query string from the Google Maps API Javascript when it is enqueued which breaks Google Maps. This is the error message that can be found in the browser console log.

    The Google Maps API server rejected your request. The "sensor" parameter specified in the request must be set to either "true" or "false".

    http://wordpress.org/extend/plugins/better-wp-security/

  2. alex80ks
    Member
    Posted 2 years ago #

    I have solve that problem by unchecking option Generate random version number in better security tweaks try it it should be working for you also.

  3. Ian Dunn
    Member
    Posted 2 years ago #

    Here's another report of this problem. You may also need to disable the "Filter suspicious query strings" option.

    Bit51, can you create a whitelist of popular URLs that are known to be safe?

  4. faina09
    Member
    Posted 2 years ago #

    Same issue, tnx @alex80ks for the solution! I do not need to disable the "Filter suspicious query strings" option, just unchecked option "Generate random version number". A fix should be great!

  5. I will look at adding a whitelist feature in future versions.

  6. mix35
    Member
    Posted 2 years ago #

    Hello faina09,

    How did you unchecked the "Generate random version number". Please help here is my email add [ redacted, support is offered via the forum and not email ] :(

  7. faina09
    Member
    Posted 2 years ago #

    system tweeks -> Display random version number to all non-administrative users

  8. signcarver
    Member
    Posted 1 year ago #

    I checked both of the suggested choices above:

    • "Filter suspicious query strings"
    • "Generate random version number"

    I am still having the problem in "all" browsers except Firefox (Problem show up in IE, Chrome, Safari and Opera)

    Please see:
    http://ezdockdealer/company/find-a-dealer

    Can you please help?

    Thanks,
    Steve

  9. Ian Dunn
    Member
    Posted 1 year ago #

    signcarver, you're supposed to uncheck them.

  10. signcarver
    Member
    Posted 1 year ago #

    DOH - Damn it Jim!

    boy do i feel silly

    unchecking works fine - thanks!

  11. xorred
    Member
    Posted 1 year ago #

    Doesn't work for me. Using the Estate theme with IDX plugin, it doesn't show the map at all with the plugin enabled. Unchecking ALL of the tweaks, removes the error message, but also hides the map...

  12. xorred
    Member
    Posted 1 year ago #

    Seems only disabling the plugin helps...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic