WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] [Plugin: Better WP Security] Fatal error: Allowed memory size (15 posts)

  1. dskmusic
    Member
    Posted 2 years ago #

    I get this message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 614746 bytes) in /home/dskmusic/public_html/wp-includes/wp-db.php on line 931

    and site is down!!!!!

    http://wordpress.org/extend/plugins/better-wp-security/

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    This is a site - not a plugin - issue. Try increasing the memory available to PHP.

  3. dskmusic
    Member
    Posted 2 years ago #

    this only happends when I activate the plugin. Yesterday works fine, today, after creating a new post, this error happends. I try to deactivate all plugins, and when activate again, this plugins cause this error.

  4. Were you using the filechecker feature? Try deleting 'bwps_filecheck' from your options table and it should take care of it. Unfortunately file checking is a VERY memory intensive feature...

  5. dskmusic
    Member
    Posted 2 years ago #

    no.. I dont have in use.. I only have 2 bwp tables:
    _bwps_lockouts
    _bwps_log

  6. faina09
    Member
    Posted 2 years ago #

    I have the same issue, and already 256M in use:

    Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /home/wp-includes/wp-db.php on line 1443, referer: http://www.mysite.org/wp-admin/admin.php?page=better-wp-security-databasebackup

    I can backup my DB (and directories too!) using, e.g. BackUpWordPress
    I am using the last plugins versions and WP 3.4

  7. @dskmusic it is in your options table.

    @faina09 256MB is more than adequate on every site I've ever tried it on. Are you using many other plugins? How large is the database?

  8. dskmusic
    Member
    Posted 2 years ago #

    @Bit51 , ok, is work again ;) thanks!

  9. faina09
    Member
    Posted 2 years ago #

    @Bit51 Yes I have a lot of plugings, about 40 but the memory used during normal operations is around 72M. (console debug plugin reposrt)
    The db itself is 12Mb (sum of tables size)

    @dskmusic please can you describe what have you done?

  10. MickeyRoush
    Member
    Posted 2 years ago #

    @ faina09

    Was the plugin working fine before updating to WordPress 3.4? The latest version of WordPress causes more memory consumption.

    I've noticed it varies from site to site. Seems like there are a lot more memory related questions at WordPress.org since the latest update. There may be a correlation.

  11. faina09
    Member
    Posted 2 years ago #

    I used it only with the new 3.4 wp version

  12. dskmusic
    Member
    Posted 2 years ago #

    I delete 'bwps_filecheck' from wordpress options table.

  13. The filecheck, by definition, is memory intensive and disabling it should solve any memory issues that can't be resolved by increasing the memory available to the application.

  14. dpipitone
    Member
    Posted 1 year ago #

    Hi. I just deleted the bwps_filecheck from the table and I am still having issues. Anyone try anything additional to resolve things?

  15. CustomDesignz
    Member
    Posted 1 year ago #

    All you need to do is edit your servers php.ini file and increase the memory size. If there isn't one then you can make one and stick it anywhere you need it. Home directory obviously will cover entire site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.