WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[Plugin: Better WP Security] Changing the Login url slug, doesn't work! (9 posts)

  1. Lee Hayward
    Member
    Posted 1 year ago #

    I've enabled the Hide Backened and changed the url's for wp-admin , login and register .. However, no matter what i change the "login" slug to the user can always still use mydomain.com/login and it gives them the login page. I've tried all kinds of things, like "authorsonly" , "22112445AA" , and they work, but so does "Login" still ;)

    Great plugin btw...

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Thanks for the report. I'll take a look at this.

  3. fchang
    Member
    Posted 1 year ago #

    Hi, I have the latest WP and latest BWPS. I have this exact same problem and getting daily attempts from bots now.

    Thanks in advance for looking into this.

  4. thealchemist
    Member
    Posted 1 year ago #

    I've got a different problem ... I changed "login" to "??" meaning I thought I'd be cute and try something unique ... only I thought I'd remember it.

    I have tried the wp-admin###### with the secret code but I still cant get in.

    Is there a work around? Can I look in the database to see what I turned it into?

  5. @thealchemist You can get it in the .htaccess

    @fchang - resave your settings with BWPS 3.4.2 and you should be fine.

  6. knobby44
    Member
    Posted 1 year ago #

    I am setting up my sites, and have a domain multisite installation.

    When I tried to change the section under Security/Hide Backend. This is supposed to set the login URL to xyz.com/login, xyz.com/admin, and xyz.com/register. That part worked.

    But, when trying to go to a subsite, like 123.com (a sub-site for the multisite install where the 123.com site is domain mapped) then the redirect or pages did not work and when trying to login (the normal login page would show up), it wouldn't even find the page for the site once the user info was entered.

    I have since unselected that to leave the login and registration pages as the default WP page URL's, but last time I did this, I was getting way too many false registrations and my site wasn't even running yet.

  7. thealchemist
    Member
    Posted 1 year ago #

    Thanks. I believe it is this line?

    RewriteRule ^login/?$ /wp-login.php?############# [R,L]

    But when I go to /login I am redirected to the home page.

    When I go to /wp-login.php?############# I get not_found

    So I am stumped.

  8. knobby44
    Member
    Posted 1 year ago #

    Well, I went and remapped my subsites last night, and now have a slightly different result.

    The current state of the login is functional, but on all my subsites, when I log into one of them, I am always re-directed to the main site and can't seem to get to the sub-site unless not logged in.

  9. @knobby44 are you using an extra plugin for domain mapping? I could see that would cause problems as the plugin is only really built to handle WP's builtin subsite addressing (subdomains or subdirectories).

    @thealchemist Can you email me at info [at] bit51 [dot] com. I would like to take a closer look to see what you have going on there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.