WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[Plugin: Better WP Security] 404 - Not Found on all site links (14 posts)

  1. njolme
    Member
    Posted 2 years ago #

    Hi,

    Getting "404 - Not Found" error on almost all pages.

    The steps I followed:

    Installed Better WP Security plugin
    Ran backup
    Turned on most plug in functionality
    Got 403 error on logout & change password pages
    Modified .htaccess file to comment out a login rewrite
    Got 500 internal error
    Deactivated Better WP Security plug in
    Deleted Better WP Security plug in
    Now getting 404 - Not Found error on all links such as:

    http://www.mysite.com/about
    http://www.mysite.com/product
    http://www.mysite.com/my-account

    However http://www.mysite.com and http://www.mysite.com/wp-admin still work, and I can still log in as admin.

    Grateful for any help to resolve this ASAP. Thanks.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. njolme
    Member
    Posted 2 years ago #

    Fixed this issue.

    Changed Settings -> Permalinks from Post Name option to Default option. Pages all became accessible so changed back to Post Name and no more problems at this stage.

  3. njolme
    Member
    Posted 2 years ago #

    Marked as resolved.

  4. Thanks for the followup. I will have a better check for that in the next few versions.

  5. westerngeomancy
    Member
    Posted 1 year ago #

    That fix worked for me too. Thanks!

  6. jugigi
    Member
    Posted 1 year ago #

    I am getting page not found message when i try to access some of my vbulletin form options, can anyone help?

  7. rainbowpig
    Member
    Posted 1 year ago #

    I have switched Permalinks, default works but post name still does not work...any idea?

    Thanks!

  8. Kimberly Gypsy LoSavio
    Member
    Posted 1 year ago #

    Thank you so much ... This has totally helped!

    CLUE -- might be a good idea to add to the FAQ section to the plugin! Will save a LOT of headaches for anyone else who goes through this. the ONLY way I found this was googling "client denied by server configuration" after I got no help from my hosting service (which btw, I may be switching from). UGH ... But YAY! No more errors!

  9. wmsuman
    Member
    Posted 1 year ago #

    What worked for me -

    • Set permalinks to default
    • Re set permalinks to day and month.

    The old (and readable) permalink structure works fine once again!

  10. tmrait
    Member
    Posted 1 year ago #

    Thanks, that worked, but needed to do a "F5" .

  11. DavidWoods
    Member
    Posted 1 year ago #

    The secret for me was that my .htaccess file needed some edits to be able to change permalinks, but better-wp-security was set to prevent edits of .htaccess!

    1. On the Security page, Tweaks tab, turn off Protect Files.

    2. Under Settings > Permalinks, change to something other than Default.

    3. Back to the Security > Tweaks tab and turn Protect Files back on!

    Protect Files was conflicting with Permalinks for me.

  12. regiscassidy
    Member
    Posted 1 year ago #

    Thanks @DavidWoods

    This almost got me there. You also need to:

    1.B On the Tweaks page, under Other Tweaks turn off uncheck "Remove write permissions from .htaccess and wp-config.php"

    3.B Turn "Remove write permissions from .htaccess and wp-config.php" back on

  13. practicaleq
    Member
    Posted 1 year ago #

    I had the same problem today. It seems to have been resolved by deactivating the plugin and then reactivating it, but I'm concerned the problem might come back. Should I do the .htaccess file edits that DavidWoods and regiscassidy specified?

  14. netlad255
    Member
    Posted 1 year ago #

    damn, wish i read this page earlier.

    i didnt have delete all the wp installation
    here my story here http://wordpress.org/support/topic/geting-404-for-all-the-internal-pages?replies=9#post-4428688

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic