WordPress.org

Ready to get started?Download WordPress

Forums

Better WordPress Recent Comments
[resolved] problem with comment link (7 posts)

  1. electrolund
    Member
    Posted 2 years ago #

    For some reason, the template use of %link% is returning links formatted like this:

    http://yoursite.com/path/postname/comment-page-1/

    ...instead of a permalink to that comment.

    I'm using the Thematic Theme framework if that matters. Is this some sort of comment grouping problem?

    http://wordpress.org/extend/plugins/bwp-recent-comments/

  2. electrolund
    Member
    Posted 2 years ago #

    Hmm, I see it's because I have the comment pagination setting in WordPress set.

    However, it's a shame that the permalink can't go to the comment page, AND to the comment. For instance, a format like this:

    http://yoursite.com/path/postname/comment-page-3/#comment-95492

  3. Khang Minh
    Member
    Plugin Author

    Posted 2 years ago #

    What is your current setting? I have #comment-ID here without issue.

  4. electrolund
    Member
    Posted 2 years ago #

    Thanks for the help, OddOneOut. I'm not sure where that variable is on the BWP RC template settings page. There's a %comment_number% referred to with comment grouping, which seems like what I'm doing. Yet, only the template for non-grouped is affecting the output.

    I tried using this format href="%comment_number%", but this didn't output anything other that my site root. I also tried a combination: %link%%comment_number%, but this too was no good.

    Here's my site where this is running:

    http://blog.cbeinternational.org/

  5. electrolund
    Member
    Posted 2 years ago #

    OddOneOut, this appears to be a problem with the Thematic theme. I switched it to the WP Twenty Eleven and now your shortcode %link% works fine. Hmm, I will have to investigate over on those forums.

    But before I leave, can you tell me what function your plugin is calling that Thematic doesn't understand?

  6. electrolund
    Member
    Posted 2 years ago #

    Well this is funny. As of today, my comment links are now working. I see them in the expected form:

    http://blogsite.com/2012/06/post-title/comment-page-1/#comment-96453

    Trying to think what changed up until now... I installed the Move WordPress Comments plugin. Not too much else except for some (supposedly) unrelated functions.php work last night. Whatevs.

  7. electrolund
    Member
    Posted 2 years ago #

    Funny again, now those links seem not to work. Very, very odd. Not sure what's happening in between these times I'm checking.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic