WordPress.org

Ready to get started?Download WordPress

Forums

Better WordPress Minify
[resolved] Fatal error when using PHP 5.4.0 (6 posts)

  1. Rickard Andersson
    Member
    Posted 2 years ago #

    After upgrading to PHP 5.4.0 the following fatal error occurred:

    Fatal error: Call-time pass-by-reference has been removed in wp-content/plugins/bwp-minify/includes/class-bwp-minify.php on line 717

    Passing by reference should be noted in the function parameter list and not in the variable being sent, http://www.php.net/manual/en/language.references.pass.php

    This patch fixes the issue at least for me

    http://files.0x539.se/random/bwp-minify-call-time-pass-by-reference.patch

    http://wordpress.org/extend/plugins/bwp-minify/

  2. Khang Minh
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks Rickard, the patch will be included in 1.2.1.

  3. sarumbear
    Member
    Posted 2 years ago #

    When can we expect 1.2.1?

  4. Riddergraniet
    Member
    Posted 1 year ago #

    C'mon, it's been 6 months now, don't you think it is time to update this version? I'm using 5.4.4 locally and it's only a matter of time before our host is going to upgrade too. Please update the repository with this patch.

  5. sarumbear
    Member
    Posted 1 year ago #

    The word 'better' in the plugin title says it all. When things are advertised as 'better' they usually are the opposite.

  6. Khang Minh
    Member
    Plugin Author

    Posted 1 year ago #

    @sarumbear: I think you're assuming a few things there.

    Anyway, I have plans to update all plugins this month, and an update for BWP Minify is guaranteed this weekend.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic