WordPress.org

Ready to get started?Download WordPress

Forums

Better WordPress Google XML Sitemaps (with sitemapindex, multi-site and Google News sitemap support)
[resolved] Incorrect sitemap address in robots.txt with MU domain mapping plugin (11 posts)

  1. nixor
    Member
    Posted 2 years ago #

    Hi, thanks a lot.
    I'm running 3 domain on WordPress 3.0 multisite.

    http://www.first-domain.com
    http://second.first-domain.com
    http://third.first-domain.com

    I'm also using wordpress MU domain mapping plugin.
    I have mapped from subdomain to www domain utilizing domain mapping.

    http://www.first-domain.com
    : Initial domain for super-admin
    http://www.second-domain.com
    : domain mapping from second.first-domain.com and primary domain marking
    http://www.third-domain.com
    : domain mapping from third.first-domain.com and primary domain marking

    but, there is issues with robots.txt

    http://www.first-domain.com/robots.txt
    Sitemap: http://www.first-domain.com/sitemapindex.xml

    http://www.second-domain.com/robots.txt
    Sitemap: http://second.first-domain.com/sitemapindex.xml

    http://www.third-domain.com/robots.txt
    Sitemap: http://third.first-domain.com/sitemapindex.xml

    one is correct and others are incorrect. - because of I have set it in primary domains.
    It should be shown up as below

    http://www.second-domain.com/robots.txt
    Sitemap: http://www.second-domain.com/sitemapindex.xml

    http://www.third-domain.com/robots.txt
    Sitemap: http://www.third-domain.com/sitemapindex.xml

    Is this BUG ?

  2. Khang Minh
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, no it is not a bug, I will implement this feature in the next version, stay tuned!

  3. Judy Nelson-Moore
    Member
    Posted 2 years ago #

    Thank you so much for planning to implement support for MU Domain Mapping in your plugin! For me, this is a priority for several multisite domains I am now implementing. Is there a manual workaround you can recommend until you are able to get it working? Like, could I copy the old sitemap to the multi-site installation? It doesn't get updated very often. Any idea when the update would come out. I hesitate to make myself a pest, but this seems so essential to the working of multi-site and you are the only one who seems to understand it.

    Thanks, Judy

  4. Khang Minh
    Member
    Plugin Author

    Posted 2 years ago #

    I'm working on a new version, and it should be released this weekend. Hope you can wait :).

  5. Judy Nelson-Moore
    Member
    Posted 2 years ago #

    Thank you, Thank you...you are a prince!

  6. nixor
    Member
    Posted 2 years ago #

    Thank you !

  7. stoutdesign
    Member
    Posted 2 years ago #

    +1 Would be so happy to see domain mapping support rolled in.

  8. mchg
    Member
    Posted 2 years ago #

    +1 it would be great with domain mapping support!!

  9. nixor
    Member
    Posted 2 years ago #

  10. nixor
    Member
    Posted 2 years ago #

    Workaround :

    1. Go Network Admin > Dashboard
    2. Click Edit of Sites > All Sites > domain
    3. Change to proper domain(for example, http://www.second-domain.com/) Settings tab > "home" field

    That's it !

  11. Khang Minh
    Member
    Plugin Author

    Posted 2 years ago #

    1.2.0 should have resolved the issue I believe. Could you please give me a link to your website?

Topic Closed

This topic has been closed to new replies.