WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Better RSS Widget] Not working (14 posts)

  1. jspragins
    Member
    Posted 3 years ago #

    i can't get this widget to display. can't figure out what i'm doing wrong.

    http://66.147.244.214/~wctrusto/?page_id=37

  2. GrandSlambert
    Member
    Posted 3 years ago #

    It appears to be displaying correctly now - or am I missing something. Let me know if you have fixed the issue.

  3. jspragins
    Member
    Posted 3 years ago #

    no - still not displaying. the widget that is displaying is the normal RSS widget, not the Better RSS Widget.

  4. GrandSlambert
    Member
    Posted 3 years ago #

    Are you adding the widget titled "Better RSS Widget" or the built in "RSS" widget? You need to be using the new "Better RSS Widget" box for this to work. The plugin DOES NOT override the built in box, just provides an alternative.

    Take a look at the updated documentation page for more details:

    http://docs.grandslambert.com/wiki/Better_RSS_Widget

  5. jspragins
    Member
    Posted 3 years ago #

    I have both widgets on the sidebar, but only the built-in RSS widget is displaying.

  6. GrandSlambert
    Member
    Posted 3 years ago #

    Did you select in the widget form the types of pages for the widget to display on? If none of those boxes are checked, it will not display. You need to check at least one of those boxes (probably all) for the widget to display.

  7. jspragins
    Member
    Posted 3 years ago #

    yes, i selected all page types for the widget to display. still no display!

  8. GrandSlambert
    Member
    Posted 3 years ago #

    The next step is to turn on WP Debug Mode and share with me any of the errors that are produced. This will help me find what is causing the problem and fix it.

    http://codex.wordpress.org/Editing_wp-config.php#Debug

  9. jspragins
    Member
    Posted 3 years ago #

    i read over the instructions and it seems like a huge project to me. i can't find the wp-config-sample.php file anywhere to edit to turn the debug thing on. argh.

  10. jspragins
    Member
    Posted 3 years ago #

    OK - i figured it out and turned debug on, please look at it quick, the page is a mess now. error messages all over the place.

    thank you for sticking with me.

  11. GrandSlambert
    Member
    Posted 3 years ago #

    OK, those errors are coming from the plugin page-links-to because the developer didn't code it very well. For the BetterRSS widget, can you take a screen shot of your widget settings for me to see? I bet it is a setting issue, such as you don't have any pages checked for where to display the thing. Go ahead and turn it off again.

    Look where you set up your widget. Under the heading "Limit this instance to" are a bunch of check boxes. Are any of those checked?

  12. GrandSlambert
    Member
    Posted 3 years ago #

    OK, I guess he information on the form is misleading. You MUST select which pages the widget will display on. I am changing that, and defaulting the settings to be on for all pages. You can uncheck them to remove them from certain pages. Version 2.5 should be easier to follow.

  13. mcsaban
    Member
    Posted 3 years ago #

    I had Rss And it was workig fine till the system reboot... Now i got message:RSS Error: A feed could not be found at http://www.slo-underground.org/feed . Now i installed Better RSS Widget but is not showing up on page :/ some help?

  14. kbenjamin
    Member
    Posted 3 years ago #

    Try making sure CURL is enabled in php.ini. It worked for me on a test WP setup using a WAMP server.

Topic Closed

This topic has been closed to new replies.

About this Topic