WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Better Extended Live Archive] Extended Live Archives is Broken (15 posts)

  1. callumalden
    Member
    Posted 4 years ago #

    Hey, I've been using wordpress for years- became very accustomed to a brilliant little archive plugin called "Extended Live Archives" which exists in development on three separate websites, the most current is the Google Code Site. Although you'll find the original plugin here and I took most of my information from the blog of Sairuh Emilus- here. Furthermore on The Glitch I found a working version for 2.7 - so close!

    ... now, I'm adding the accumulated patches, hacks and thoughtfulness of many bloggers / forum posters to create a semi-working ELA for wordpress 2.8.4.

    as explained in my post, it doesn't quite work! it seems to be doing the business on the backend and the PHP looks good too. any ideas? anyone remotely interested in this great plugin anymore: view the official wordpress plugin page here.

  2. anatman
    Member
    Posted 4 years ago #

    Hey callumalden,
    I had ELA working in my 2.8.4 installation, before you published your patch. I followed instructions from a few different sources. I am not 100% sure i can reconstruct my research path...
    Please take a look here: http://acupuntura.pro.br/indice , does it look ok to you? I know, the colors are kind of weird, but the plugin works, right?

  3. callumalden
    Member
    Posted 4 years ago #

    Woah! That's great, could you possibly navigate through your wordpress install to the plugins directory, and copy the Extended Live Archive (or af-live-archives OR better-live-archives or... whatever?!) folder to your desktop, maybe we could re-realease this plugin for the WP community at large.

    If you could mail me a copy (best to .zip that first!) to me I'd be grateful!

  4. onkelandy
    Member
    Posted 4 years ago #

    Oh I would love to get the 2.8 working version, too! Anatman, can you put it online somewhere or mail it?

  5. callumalden
    Member
    Posted 4 years ago #

    @onkelandy i've got a hold of anatman's patched (re-patched and patched again!) version of ELA. he's very kindly offering it up to the greater good of the ELA community. i'm going to host it soon, but there's currently an issue with PHP 4 which is stalling progress.

    i'll certainly post it on to you if you're on PHP 5 it should just work!

  6. Hugh
    Member
    Posted 4 years ago #

    @callumalden

    Could you post the link? I am on PHP5 but I didn't see where to download this at.

  7. callumalden
    Member
    Posted 4 years ago #

    @sil.linguist & @onkelandy if you're running PHP 5 then Eduardo's version of ELA (which I've hosted here on my site)

    That should help you get up and running... i'm still working on the general update. as is Charles at http://sexywp.com/ - so check those links out, report back with an update if you could!

  8. onkelandy
    Member
    Posted 4 years ago #

    Hi again! Thanks for the updates! As I'm runnning PHP 5 everything seems to run fine.. mostly. There is one big problem though - I'm wondering if anyone else has it. As soon as I have WP-dTree Plugin running, ELA doesn't show up anymore!? So there must be some sort of conflict.

    First I thought it's the prototype and scriptaculous javascript but with manual loading of the two JS files and deactivated WP-dtree everything works fine. So I have no clue what the problem actually is :( Any idea?

  9. callumalden
    Member
    Posted 4 years ago #

    that's good news- i've just updated a client's blog to PHP 5 and i'm about to give it a shot with the ELA patch by anatman - he is the man!

    re. WP-dTree; i'm unfamiliar with that plugin... so, i'm a little lost, maybe the two plugins are calling the 'actions' to the JS / ajax stuff and that's causing a conflict- but you'd expect some kind of error message?! have you taken this to their forums? sorry i couldn't be more help on that one onkelandy!

  10. callumalden
    Member
    Posted 4 years ago #

    hmm, still not working for me (now on PHP 5) I'm using a shared server with Media Temple, so I might ask them what's up(?). But I think this plugin is going to have to be re-written from the ground up. there's a lot of code in there I just don't understand.

    ANYWAY: Charles has updated his 'Better Live Archives' to 0.40 btw, you can find that over here: http://wordpress.org/extend/plugins/better-extended-live-archive/

    Probably best to stick with his plugin at the moment, if you don't have any joy with the links I've previously provided. He is working on a fix for WordPress 2.8.4

  11. callumalden
    Member
    Posted 4 years ago #

    UPDATE: i had an edit in the functions.php file that was causing a problem with extended live archives.

    If you are encountering problems: Deactivate ALL Plugins, then download, install and activate the plugin patch from my site. If problems persist- look into that functions.php file- I think it's a header conflict.

    Great News: Extended Live Archive works for WordPress 2.8.4

  12. onkelandy
    Member
    Posted 4 years ago #

    Thanks a lot for your effort! I still keep having the problems with wp-dtree in combination with ELA.. Can you explain those functions.php problems a little bit more please?

  13. onkelandy
    Member
    Posted 4 years ago #

    still need help with the conflict with wp-dtree.. thanks alot!

  14. Hugh
    Member
    Posted 4 years ago #

    the version from WP Extend works with WP 2.9

  15. onkelandy
    Member
    Posted 4 years ago #

    Yep, everything seems to work fine! Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic