WordPress.org

Ready to get started?Download WordPress

Forums

Manual Related Posts
[resolved] shortcode doesn'work? (19 posts)

  1. laurentcoco
    Member
    Posted 1 year ago #

    Hi
    Since upgrades to 1.62 my shortcode dosn'work.
    thx

    http://wordpress.org/extend/plugins/baw-manual-related-posts/

  2. Julio Potier
    Member
    Plugin Author

    Posted 1 year ago #

    Hello

    Can you try the 1.6.3 ?

    Thank you

  3. laurentcoco
    Member
    Posted 1 year ago #

    Hello
    1.63 is ok thank you very much

  4. pieterkoster
    Member
    Posted 1 year ago #

    Hi,

    Nice plugin. I want to use it on our site, but I can't get it to work with the PHP shortcode. I just installed the plugin today, version 1.6.3. Are you sure this issue should be fixed in 1.6.3? Or maybe I do something wrong.

    In my single.php template I call:
    <?php echo do_shortcode( '[manual_related_posts]' ) ; ?>

    But nothing is visible on the post where I added some manual related posts. However, when I enable the option to fill the related posts automatically, I DO get those related posts visible. But only in posts where no manual posts are selected, they remain empty.

    Hope you can help!

  5. flandreau
    Member
    Posted 1 year ago #

    Hello,

    I have the same problem with the shortcode. I just installed this plugin in 1.6.3 version. My WP version is 3.4.2. I add related post in the admin by editing a post. I have added the shortcode in my index.php template. And nothing appears in the post.

    Thanks

    François

  6. Jason Lemahieu (MadtownLems)
    Member
    Posted 1 year ago #

    Francois wrote:

    I have added the shortcode in my index.php template

    Did you add the _shortcode_, or the do_shortcode(...) code? Shortcodes go in the posts themselves, do_shortcode(...) goes in php files

    (The shortcode works fine for me)

  7. flandreau
    Member
    Posted 1 year ago #

    I have added the <?php echo do_shortcode( '[manual_related_posts]' ); ?>
    in the index.php file. I treid also with the one '[manual_related_posts]' in my edited post but was not lucky with each one.

  8. Julio Potier
    Member
    Plugin Author

    Posted 1 year ago #

    Damn, ok let me see this, i'm on the 1.7 version, will be fix soon and released soon.
    Sorry :/

  9. happyweb
    Member
    Posted 1 year ago #

    Bonjour,

    Je suis vraiment impressionné par le nombre de plantages de ce plugin !
    Warning: shuffle() expects parameter 1 to be array, null given in .../wp-content/plugins/baw-manual-related-posts/inc/frontend-noajax.inc.php on line 22

    Warning: implode() [function.implode]: Invalid arguments passed in
    .../wp-content/plugins/baw-manual-related-posts/inc/frontend-noajax.inc.php

    De plus le shortcode ne fonctionne pas, et pour couronner le tout la documentation est inexistante, notamment concernant le système de cache... Ce qui fait que malgré le changement d'option c,est toujours les premières choisies qui s'affichent :(

    Vraiment dommage parce que l’idée était bonne... Sauf que les brouillons dans la recherche pour l ajout manuel... euh y a un concept ?

    Testé avec WP 3.4.2

  10. happyweb
    Member
    Posted 1 year ago #

    Bonjour,

    Oh une mise a jour ! Je teste et BAW ! Pratiquement aucune amélioration :(

    Et pourtant j'en ai fait des tests !

    Toujours ce message :

    Warning: implode() [function.implode]: Invalid arguments passed in /home/www/bf2c9d7ffcf03369d3ff5780e8e16647/web/wp-content/plugins/baw-manual-related-posts/inc/frontend-noajax.inc.php on line 23

    dans les posts du jours mais pas dans les autres apparemment... j'ai tout tester mais ca revient...

    et

    Warning: in_array() expects parameter 2 to be array, null given in /home/www/bf2c9d7ffcf03369d3ff5780e8e16647/web/wp-content/plugins/baw-manual-related-posts/inc/frontend-noajax.inc.php on line 44

    si j'active le fonction d articles relatifs auto

    Bon ben je re-désactive :(

    Note : Pas de css pour la mise en forme ? Pourquoi pouvoir rentrer du html pr le titre < h3 > qd y a pas d articles (prefs) et pas possible pour le titre vous aimerez aussi ? Un petit < br / > serait pourtant bienvenue... avant et apres le h3 --'

    Jusqu'ici 2H de perdues... Bon ce qui m’étonne le plus et ce qui m’énerve grave, c'est que vu les conseils que tu donnes sur ton blog, tu puisses proposer un truc pareil !

    Je code pas moi même et j'imagine bien que ça doit pas être simple mais bon depuis que je teste des plugins c'est quasiment la 1ere fois que je vois un aussi inachevé :(((

    Remarque si j'avais suivit tes conseils j'aurai jamais installé ce truc la ;)

  11. Julio Potier
    Member
    Plugin Author

    Posted 1 year ago #

    This is english forums, please speak english.
    ps: you better rename to "rageWeb" ;)

  12. Julio Potier
    Member
    Plugin Author

    Posted 1 year ago #

    1.7.7 is out, HTML supported for front end title, a CSS class was already present to customize style since the plugin's birth (<div class="bawmrp">), i hope warnings are fixed and you can link draft posts if you know that when this draft will be published, you'll need to link it. Do it before, not after. It won't be displayed is not published.
    By the way, transports-en-commun.info is not allowed to use the plugin, you win.

  13. laurentcoco
    Member
    Posted 1 year ago #

    hello julio
    version 1.77 works well with the posts manually but still causes errors automatically .
    Also the shotcode creates the same error
    I could be more explicit in french
    cdt

  14. Julio Potier
    Member
    Plugin Author

    Posted 1 year ago #

    come on skype julio.boiteaweb or gtalk juliobosk@gmail.com

  15. Julio! My friend! A request! Could you setup a contact page and use that sometime in the future? If you don't want to that is of course fine too.

    Your plugin support is really good and appreciated but I develop a rash when I come across email addresses or Skype in the forums. ;)

  16. Julio Potier
    Member
    Plugin Author

    Posted 1 year ago #

    I always want that people come on support forum when they need help and not directly on mail/skype/gtalk.
    I hate that :]

  17. piglesias
    Member
    Posted 1 year ago #

    Hi Julio!

    At first, many thanks for developing this helpful plugin.

    Now, my issue:

    In version 1.7.9, shortcode into single.php just works if " Will be displayed at bottom of content" is checked, and then, of course, it shows twice.

    At least, in my WP installation...

  18. Julio Potier
    Member
    Plugin Author

    Posted 1 year ago #

    1.7.10 is out and fixed this ;)

  19. desarrollo@avantine.com
    Member
    Posted 10 months ago #

    In version 1.7.17 as in 1.7.9, shortcode into single.php just works if " Will be displayed at bottom of content" is checked, and then, of course, it shows twice.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.