WordPress.org

Ready to get started?Download WordPress

Forums

Basic Google Maps Placemarks
[resolved] Placemarks content to display fully (3 posts)

  1. GPStracks.tv
    Member
    Posted 2 years ago #

    Hello,

    Congratulations for the excellent work. I´m using Basic Google Maps Placemarks at my site GPStracks.tv as the main entry page and I love it.

    There is nevertheless a little glitch that keeps annoying me: I have to click twice on a placemark in order to display its content fully, since the first time I click on it only half of the content is displayed. Please try it yourself live to see what I mean.

    Since it is the main entry point to my site the behaviour of placemarks is very important for me, therefore I would therefore appreciate a lot being given a solution or maybe just some clues about how to workaround it by hacking around the code if necessary.

    Best regards,
    Jorge

    http://wordpress.org/extend/plugins/basic-google-maps-placemarks/

  2. Ian Dunn
    Member
    Plugin Author

    Posted 2 years ago #

    It seems like the info window is big enough at first, when there's only text, but then the image loads and the window doesn't resize to fit it. I think it should do that by default, though.

    How are you inserting image into post? Just through the standard process with the WYSIWYG editor?

    It could be that your theme or another plugin is altering the way images are loaded, or has some CSS rules that are affecting it. Try disabling all other plugins and switching to TwentyEleven to see if that fixes it. If it does, isolate which plugin or theme is causing the problem.

    You can also force the size of the info window with your own CSS rules. See the FAQ for details.

  3. Ian Dunn
    Member
    Plugin Author

    Posted 2 years ago #

    I just ran into this on a site I'm working on for a client and found a CSS rule that's causing the problem. Here's what it looks like by default:

    #bgmp_map-canvas img
    {
    	...
    	height: auto !important;
    	...
    }

    To fix the problem, change that to:

    #bgmp_map-canvas img
    {
    	...
    	/*height: auto !important;*/
    	...
    }

    (or override it in your theme's stylesheet.

    I'll fix it in the next release of the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic