WordPress.org

Ready to get started?Download WordPress

Forums

Basic Comment Quicktags
[resolved] Auto-Activates and Incorrect Application/Saving of Toggled States (4 posts)

  1. MomDad
    Member
    Posted 1 year ago #

    Ironically and contrary to the description, this plugin does in fact auto-activate. Upon installation, and going to Settings > Discussion, you'll find that both checkboxes are initially already checked, yet when looking at a post comment form, or bbPress reply form, neither have the quicktags bar visible.

    There is definitely something wonky. I just did a test of all combinations of the two options.

    bbPress checked, comments checked - quicktags visible on both (OK)

    bbPress unchecked, comments checked - quicktags not visible on either (they should be visible on comments)

    bbPress checked, comments unchecked - quicktags visible on both (they should only be visible on bbPress)

    bbPress unchecked, comments unchecked - settings page reloads and now both options are checked and the quicktags are visible (should instead both be unchecked and quicktags should not be visible on either) -- you can't get it into a state of both being unchecked/disabled.

    It's a very handy little plugin, though unusable for me in it's current form since it's impossible to get it into the state of having comment quicktags on, bbPress off. I hope to see it updated with these issues addressed.

    http://wordpress.org/extend/plugins/basic-comment-quicktags/

  2. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 1 year ago #

    Well that's not right... I'll have a look this weekend, see if I can kick it a bit. I may end up reverting to just being on for both all the time, the switch has been problematic :/

  3. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 1 year ago #

    Okay version 1.4 is on the way, should fix this. I left something on for testing. Silly me :D

  4. MomDad
    Member
    Posted 1 year ago #

    That did the trick -- it works a treat now! :D

    Thanks for the speedy fix, Mika, and for all your other great plugins -- I'm a big fan.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic