WordPress.org

Ready to get started?Download WordPress

Forums

Backup
Works Great! Need help with folder ids though... (4 posts)

  1. Jason
    Member
    Posted 1 year ago #

    First off, I must say, I love this plugin!

    I'm using it on WordPress 3.4.1 Multisite, with BuddyPress 1.6 AND MultiNetwork.

    I used this guide which was very helpful
    http://www.wpsquare.com/backup-wordpress-blog-google-drive/

    Still testing everything out, but after about 30 mins setup (I'm a very advanced user) It works like a charm. Things I had to overcome:
    Lack of documentation
    PHP Server was timing out before the zip file was completed (Suhosin
    extra php security won't allow php scripts to adjust php config during runtime)
    a few other more negligible issues, which are pretty typical with any wp plugin that operates a little outside of the word press environment.

    I still need to know how to find a folder id?
    Actually, I think I figured it out.... it's in the URL when your on web-based Gdrive right? I still can't get that to work...

    http://wordpress.org/extend/plugins/backup/

  2. hel.io
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jason,

    I'm glad you like the plugin. There is some documentation built right into the plugin. Just click the help button on the top right of the Backup Settings page.

    From there you can read that you can in fact get the ID of the Drive folder from the URL. The ID is the part that comes just after #folders/.

  3. Jason
    Member
    Posted 1 year ago #

    Oh I see. In my case I couldn't access that as I have that feature in wp turned off. I'm still trying to get it to upload to my folder. Will post if successful or not. Conceptually, this plugin is really cool, and seems to be well executed. Refinement is always possible of course, that's the nature of things, and hopefully Google won't be breaking it for you any time soon!

    I'm so used to the docs being shipped along with the plugin that I don't look there anyway.

    I've almost got everything working, but I noticed a new issue with cloudflare. Since my pages are being called through a cdn proxy, the http://website.com?backup=r23oi%key%23fsdf doesn't actually work, as that page is being cached. So I had to manually set a rule to disable caching on that page. Just in case anyone else runs into that with cloudflare.

  4. Jason
    Member
    Posted 1 year ago #

    When I access the manual backup URL, it shows a white screen. After just trying over and over eventually I get a title that says "Backup Process"

    I wish there was a way to call it manually without hitting an external url like that. Like with a post var instead of a url parameter.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.