WordPress.org

Ready to get started?Download WordPress

Forums

Backup
Authorization failed! (8 posts)

  1. toonwolf
    Member
    Posted 2 years ago #

    Running version 2.0 of the backup plugin. I get an error message on the settings page: Authorization failed! SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    Running WP 3.4 in a development environment W2K3, XAMPP 1.7.7, PHP Version 5.3.8

    http://wordpress.org/extend/plugins/backup/

  2. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    Looks to me like you're missing the CA cert bundle. Giving this a read might help:
    http://curl.haxx.se/docs/sslcerts.html

  3. elarno01
    Member
    Posted 2 years ago #

    the link above is over my head & I am getting a similar error, any suggestion on ligher reading? :)
    Here's what I'm Getting:
    error setting certificate verify locations: CAfile: /etc/ssl/certs/ca-certificates.crt CApath: none

    Thanks

  4. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    I don't know where else to direct you, I'm not very familiar with the problem, it's not a problem with the Backup plugin.

    I could add an option in the plugin to bypass SSL certificate verification, which would make it work for you guys but that's a really bad idea.

    Maybe someone from these forums with more authority on the matter can shed some more light on the issue.

  5. ZaPPZion
    Member
    Posted 2 years ago #

    I'm running into the exact same problem. I didn't have the problem using an older version of Backup, so I'm going to revert back unfortunately. I don't know what it is, but I think some expert is going to have to look into it. Is there any chance there's a problem with Windows hosting? I'm on Windows hosting, so might have to do something with it?

  6. palealez
    Member
    Posted 2 years ago #

    I believe i found a solution to the problem as it now works for me on a win2008r2 box.

    1. download the pem file from http://curl.haxx.se/docs/caextract.html and rename it to curl-ca-bundle.crt
    2. copy it to the c:/windows directory
    3. add the following line of code to class-http.php in your wwwroot/wp-includes directory, where the other group of curl_setopt calls are made. around line 1080 on my version of the file.
    curl_setopt($handle, CURLOPT_CAINFO, 'c:/windows/curl-ca-bundle.crt');

    you should be right to go.

  7. hel.io
    Member
    Plugin Author

    Posted 2 years ago #

    That seems to be a working solution but I don't recommend modifying WordPress core files.

    There should be a folder where you can put the bundle file without the need to add the curl option in PHP, a folder where curl expects that file to be in.

    If you have PHP >= 5.3.7 you can add this line in your php.ini file in the [PHP] section:
    curl.cainfo = c:\path\to\curl-ca-bundle.crt

  8. CraigFaraday
    Member
    Posted 2 years ago #

    Sorry hel.in I cant seem to find another way to contact just wanting to find out what happened with the wordpress (backup) plugin ?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.