WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
[resolved] Link in background not working (14 posts)

  1. agiovine
    Member
    Posted 2 years ago #

    Hi there-

    Again, great plugin!
    I think I am missing something. I added a link in in the Background URL field within the image options, but it doesn't seem to work. Does the entire background become a link or is there a certain plac ein the background that becomes a link?

    Thanks again

    http://wordpress.org/extend/plugins/background-manager/

  2. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    The entire background will become a link.

    However, as the background is hidden behind the theme, I've seen a few instances where the theme itself interferes with this (by covering the background image with transparent elements).

    If you can provide a URL where I can see the plugin in action, I'd be happy to have a look and provide you with a more clear answer.

  3. teleanu
    Member
    Posted 2 years ago #

    The link doesn't work on my blog to. link http://www.styles.ro . Thank you.

    I'v respected the faq from the plugin page.

  4. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Teleanu,

    The Javascript for Background Manager does not appear to be loading, which due to a bug can happen in certain cases. There's a development version available, which should address that bug.

  5. teleanu
    Member
    Posted 2 years ago #

    I installed the Development Version, but the link only works in full screen option. in Normal mode doesn't work.

  6. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi teleanu!

    Can you verify that on at the bottom of the Settings screen the version is "Background Manager 1.0.25-dev44"? What you'd mentioned (not able to click when selecting "Normal" mode) was resolved in the Development version quite a while ago, so hoping it hasn't regressed.

  7. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    I just had another look at your website, and you are indeed using 1.0.25-dev44. Based on that, I've found another little bug, which should solve what you were experiencing between normal mode and full screen.

    At the moment you do not have an active background set, so I wasn't able to test it any further. I'll let you know when the update is available.

  8. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Just a heads up, teleanu, that I've updated the development version which should provide a fix for the issue you were experiencing. It's at 1.0.25-dev45 now.

  9. teleanu
    Member
    Posted 2 years ago #

    thank you. i will get the .45 version and i will come back with feedback.

  10. teleanu
    Member
    Posted 2 years ago #

    Works fine, but i'v noticed that the header part is not clickable :) in rest is ok. work in normal mode to & that's super.

  11. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    If the image cannot be clicked in the header, then it may have been covered by a theme element (thought perhaps invisible, due to margins or padding). This is theme dependent, unfortunately.

  12. agiovine
    Member
    Posted 2 years ago #

    Hey - I actually just figured it out for my own site - the z-index in pub.css -1996 was the culprit

  13. agiovine
    Member
    Posted 2 years ago #

    One more question - how can I make the link in the background image open in a new window? Thanks!

  14. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi!

    Glad you got it resolved, though interesting to know it was the z-index that interfered.

    As for the link, the Development Version supports it (see http://wordpress.org/extend/plugins/background-manager/developers/). It will be available in the stable version soon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.