WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
[resolved] hide background in print stylesheet (5 posts)

  1. andrea armstrong
    Member
    Posted 2 years ago #

    Background manager is working great for me, except that I need it to not display when the pages print. I have tried to "display: none" it, but it is not working. Here's how it looks in my printstyle.css:

    #myatu_bgm_bg_link, .myatu_bgm_fs, #myatu_bgm_top, .myatu_bgm_fs { display: none; }

    Is there a class or id that I'm missing? Or any other way to override the background?

    http://wordpress.org/extend/plugins/background-manager/

  2. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Andrea,

    The following CSS should take care of that:

    @media print {
       .myatu_bgm_fs { display: none !important; }
       body { background-image: none !important; }
    }

    This can be added to the Image Set in the Custom Stylesheet box.

  3. andrea armstrong
    Member
    Posted 2 years ago #

    Hm, this hasn't worked for me. I've got it in the custom stylesheet box, as well as my own printstyle.css.
    Here is the site I'm working on: http://co-here.ca/

  4. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, sorry - there's a need to add "!important" to the CSS style you have in your css, like so:

    @media print
    {
      #myatu_bgm_bg_link, .myatu_bgm_fs, #myatu_bgm_top, .myatu_bgm_fs, .myatu_bgm_info_blk, background-image {display:none !important;}
      }

    I'll make this an option from within Background Manager for the next release.

  5. andrea armstrong
    Member
    Posted 2 years ago #

    Yes! That worked. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic