WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
[resolved] Fatal Error on Settings (7 posts)

  1. karenborchert
    Member
    Posted 2 years ago #

    Successfully installed the Background Manager plugin (newest version). Can add and edit image sets, but the Settings page gives the following error:
    Fatal error: Out of memory (allocated 11534336) (tried to allocate 745 bytes) in /homepages/26/d337745645/htdocs/wp-content/plugins/background-manager/vendor/Twig/lib/Twig/Compiler.php on line 132

    Have re-installed twice to no avail.

    http://wordpress.org/extend/plugins/background-manager/

  2. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Your PHP installation seems to be limited in how much memory it is allowed to use, and it appears to be quite low from what I can tell, even for WordPress installations.

    Although WordPress should already do this for you, try adding the following two lines to your /wp-config.php file (located where WordPress is installed):

    define('WP_MEMORY_LIMIT', '64M');
    define('WP_MAX_MEMORY_LIMIT', '256M');

    If you are using Apache/Linux to host your website, you could also try adding the following line to your .htaccess file:

    php_value memory_limit 64M

  3. micbean
    Member
    Posted 2 years ago #

    Dear Myatu Member,

    I've tried this but without luck.

    On the website I've got the following message: Fatal error: Out of memory (allocated 10747904) (tried to allocate 72 bytes) in /homepages/6/d187437416/htdocs/dev/wp-content/plugins/background-manager/vendor/Twig/lib/Twig/Node.php on line 225

    And under the settings I've got this: Fatal error: Out of memory (allocated 10747904) (tried to allocate 36 bytes) in /homepages/6/d187437416/htdocs/dev/wp-content/plugins/background-manager/vendor/Twig/lib/Twig/Lexer.php on line 358

    I've added the following to the wp-config.php

    define('WP_MEMORY_LIMIT', '64M');
    define('WP_MAX_MEMORY_LIMIT', '256M');

    I'm using 1&1. Any other suggestions what I could try?

    Regards,

    Michael

  4. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hello Michael,

    It looks like your current limit is set at 10M, which is very low indeed.

    However, with 1&1 you can use a PHP.INI file to override the settings. Please see the 1&1 FAQ regarding this.

    You would want to set the following: memory_limit = 64M

    Hope this helps!

  5. micbean
    Member
    Posted 2 years ago #

    Thank you very much for your suggestion.

    Sadly is doesn't seem to work.

    I've saved a PHP.INI file to folder and subfolders of my website. The only info in the file is "memory_limit = 64M" (is this correct).

    Still says the same under settings and on the website.

    Regards,

    Michael

  6. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Unfortunately, I do not have any other suggestions, other than trying to upgrade the hosting package or use a different provider.

    It is something that 1&1 needs to address, as a Google search on "php memory limit 1and1" yields a rather large amount of issues (and no solutions), particularly with regards to WordPress and Drupal installations.

    Sorry about that :(

  7. micbean
    Member
    Posted 2 years ago #

    okay,

    thanks for your suggestions. I'll contact 1&1

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic